Windows RealVNC server not accepting connections

Mike Miller mbmiller+l at gmail.com
Fri Oct 28 10:07:17 BST 2011


I'm running the latest Free RealVNC server in service mode on a WinXP box 
and it isn't accepting any connections.  I tried to connect to localhost 
and I get a dialog box right away saying the connection closed 
unexpectedly.  I'm not prompted for a password.

The icon is in the tray saying it is running.

What do you recommend I do to troubleshoot this?

I found the log in the Windows Event Viewer.  When I look at properties, 
this is what I see for every attempt from localhost:

SocketManager: unknown listener event: 0

But when I try to connect from a Linux machine on the subnet, it doesn't 
register anything.  When I use nmap on the Linux box to look at the 
Windows box, I see that port 5900 is "filtered" rather than "open".

I was able to use "vncviewer -listen" on the Linux box to receive a 
connection from the VNC server on Windows.  That worked but only 
momentarily.  It locked up almost right away and then the VNC server 
crashed on Windows, including the usual Microsoft request to report the 
error, which I did.

Mike



More information about the VNC-List mailing list