Indirect connection works better

Philip Herlihy Philip at
Mon May 18 20:24:23 BST 2009

Something else I found:  Try this in a command prompt (XP SP1+):

Netsh firewall show icmpsetting
Netsh firewall set  icmpsetting, REM doesn't change anything, just shows


Philip Herlihy	 

-----Original Message-----
Sent: 18 May 2009 20:11
Subject: RE: Indirect connection works better

Thanks to John, and James, for very interesting pointers.

I'll experiment on the affected systems and see what I can demonstrate, but
I'd like some feedback on these ideas first, if anyone has any!

As I understand it, MTU (Maximum Transmission Unit) describes the size of
the largest packet to (be expected to) get through the network without being
fragmented.  Different types of network (e.g. dial-up) work best with
different sizes of MTU.  The default (if there is one) is 1500, with other
sizes down to 1400 being suggested for different situations.  Netgear
suggest trying 1400 to "solve most problems":

This article describes an empirical way of checking what MTU works best in a
given situation:

Now, in the situation I'm most concerned about, I have my machine, my router
(on which I can change the MTU at will), the office router (ditto), two
wireless access points (neither have an MTU setting) and the destination
machine(s).  Changing the MTU on the end machines will involve a registry
hack after identifying the interface:
Am I right in thinking that if I lower the MTU on any one of them, it'll be
effective across the entire connection?  Which one should I change first?

I've also remembered a situation I encountered some years ago when a
firewall was found to be blocking ICMP packets.  For anyone following this,
ICMP is a collection (as I understand it) of "control" protocols which can
be necessary for a TCP connection to "tune" itself.  See: 
I found (can't remember the details) that allowing ICMP unblocked this
particular jam.  See:

Is this likely to be relevant here?  I could do with someone who actually
knows more than I can find on Google to share some experience!

Philip Herlihy	 

-----Original Message-----
Behalf Of John Serink
Sent: 15 May 2009 01:37
Subject: Re: Indirect connection works better

You have an MTU issue.
If you have access to the router/gateway you need to put a tcp mssadjust
xxxx command in the outgoing interface, usually eth0 or something like that
where xxxx is the max mtu of you internet connection.

A more painful alternative is to change the mtu on the individual machine
giving you problems.


----- Original Message -----
Sent: Fri May 15 02:34:03 2009
Subject: Indirect connection works better

Recent came across a situation again which has puzzled me in the past.  I'm
trying to connect to a machine running VNC Free edition in an office.  I can
make the connection (having set up port forwarding on the router) but it
hangs, with only the top third of the screen visible after several minutes.
Further attempts produced the same result.
That office has a workstation used as a simple workstation.  Unlike the
"target" machine, which is wirelessly connected, this one is connected to
the router by cable.  I can connect reliably to the fileserver PC.  I found
that within my remote session I could start a new session from the
fileserver PC to the target PC, and this worked well.
Now that's using the same links, but in two jumps instead of one.  What's
going on?
Phil, London
VNC-List mailing list
To remove yourself from the list visit:
VNC-List mailing list
To remove yourself from the list visit:

mailing list