unable to open display

Robert Van Overmeiren rvanovermeiren "at" vcommerce.com
Sat Aug 12 06:58:00 2006


Hello,



I'd like to use Cygwin and openSSH (Windoz XP) to connect to an SSH
gateway (Linux) and view a vncserver running on a workstation (Fedora5
Linux). I've upgraded to Free VNC 4.2.1, configured font paths, tested
textual and graphical desktop, and was able to run vncviewer while SSH'd
into the gateway from the workstation (also the vncserver).



Since I can log into the gateway from a gnome client (Fedora), and
invoke a remote vncviewer successfully, but when I log into the gateway
from a cygwin client (XP) and invoke the remote vncviewer, I get 'unable
to open display', I think there's a problem with Cygwin's gnome
libraries.



On my cygwin, I believe I installed all the network and gnome packages.
Do I need more xwindow packages or does vncviewer need to be added?



I'm just connecting to the gateway with:



  $ ssh -X username "at" gateway



Then I run vncviewer



  $ vncviewer workstation:1



There's a lot you can do with xstartup settings and ssh commands. Should
I do it differently?



I tried this on the gateway:



DISPLAY=:0.0 ssh -f -Y -l username "at" gateway gnome-session



...but got:



  Cannot fork into background without a command to execute



I tried the same on the workstation



DISPLAY=:0.0 ssh -f -Y -l username "at" workstation gnome-session



...but got:



Warning: No xauth data; using fake authentication data for X11
forwarding.

Xlib: connection to "localhost:10.0" refused by server

Xlib: Invalid MIT-MAGIC-COOKIE-1 key

(gnome-session:30816): Gtk-WARNING **: cannot open display





What are the correct packages and commands for making this vncviewer
connection?





Thx,

Robert Van Overmeiren