VPN and VNC Again

John Aldrich JAldrich "at" covista.com
Fri Nov 18 16:50:02 2005


Amy:
There is an issue with SOME VPNs that causes problems with VNC. This does
not seem to be the case with your problem, at least not the same problem as
others have had. You can test to see if port 5900 is blocked by going to
start ->Run ->telnet (enter) then type "open <hostname> 5900" and see if you
get a black screen with "RFBx.yz" (where xy and z are numbers). If you
don't, then there is something blocking port 5900 to your desktop PC. If you
do, get back to us and we'll try to help you some more. 
	John


-----Original Message-----
From: Ramsdell, Amy [mailto:aramsdel "at" bnl.gov]
Sent: Friday, November 18, 2005 11:35 AM
To: John Aldrich; vnc-list "at" realvnc.com
Subject: RE: VPN and VNC Again


Hi John,
I get a connection timeout error when I type in the IP address in the VNC
viewer.  I never get the password prompt.  The work PC is Windows 2000
Professional and the home PC is XP.  What firewall are you talking about?  I
have a VPN connection which gets me through the firewall I thought.  Once I
am the VPN connection in I can use Remote Desktop application to get from my
home XP to 2 Windows 2000 servers (one in the internal network and one in
the network DMZ).  So it would seem that I could also use the VNC viewer.  I
have Zone alarm, I think, at home.  I had turned it off at one point and
tried the connection but still got the connection timeout.
 
One weird thing is I can type in the machine name in the VNC Viewer (minus
the true domain) and get a different error message.  For instance,
name.domain.gov gets an error about being in a database but not being able
to resolve or something (I can copy out the error next time I log on if that
will help) but if I type in the workstation's true domain name, Ex
name.subdomain.domain.gov I get the connection timeout.  
 
What I can't understand is if it is a VPN issue, why would I be able to ping
the workstation just fine? How can I test if somehow that port 5900 is
blocked even when I am in the VPN?
 
(Yes, that was a mistake, sorry James! I thought I had resent it to the list
after I realized what I did)
 
Thanks!
Amy
 
-----Original Message----- 
From: John Aldrich [mailto:JAldrich "at" covista.com] 
Sent: Fri 11/18/2005 10:06 AM 
To: Ramsdell, Amy; vnc-list "at" realvnc.com 
Cc: 
Subject: RE: VPN and VNC Again



	Amy:
	There seem to be a lot of problems with VPN. A bit more info would
really
	help us diagnose your problem and get you up and running. First,
what do you
	mean by "I can't get it working"? Do you get a password prompt,
followed by
	an all-black screen and then a disconnect? If so, that's a fairly
common
	problem, and will require a bit of technical "know-how" to fix. Do
you just
	not even get a password prompt? What operating systems are we
talking about
	here? Is your workstation at the office Windows XP, and do you have
the
	firewall enabled?
	
	Please get back to us with more details. Just remember, that this is
	primarily a user-to-user support, even though James Weatherall from
RealVNC
	hangs out in this group...
	        John
	
	-----Original Message-----
	From: vnc-list-admin "at" realvnc.com
[mailto:vnc-list-admin "at" realvnc.com]On
	Behalf Of Ramsdell, Amy
	Sent: Thursday, November 17, 2005 9:19 PM
	To: vnc-list "at" realvnc.com
	Subject: VPN and VNC Again
	
	
	Forgive if the answer to this question is in past lists.  I have
been
	searching and can't seem to find it.
	
	        
	        I am using Cisco's VPN Client 4.0.1 to access the lan at
work.  I
	can remote desktop into the servers that I need to get to once I
have the
	VPN connection.  My problem is I installed RealVNC server on my work
pc
	(Windows 2000) to try to access it from home using the VNCViewer and
I can't
	get it working.
	        
	        While I am tunneled in to the LAN I can ping my work pc, but
I get a
	connection timed out if I enter that same IP into the Viewer.  At
work, to
	test I tried to connect to my work pc from my work pc (the VNC
server). I
	can connect using both the Java Viewer and the VNC Viewer so I
assume the
	VNC server is configured correctly.
	        
	        From home thru the VPN to connect to any shared drives I
always have
	to log in with my network password.  I am wondering if this has
something to
	do with it.  Reading the lists, someone had mentioned after you make
a
	connection this way or in Outlook you should be able to use the VNC
Viewer
	but I still can't. 
	        
	        Any advice for a non-techy?
	        
	        Thanks,
	        Amy
	_______________________________________________
	VNC-List mailing list
	VNC-List "at" realvnc.com
	To remove yourself from the list visit:
	http://www.realvnc.com/mailman/listinfo/vnc-list