Setenv Variables on a VNC Session

Kaplan, Andrew H. AHKAPLAN "at" PARTNERS.ORG
Tue Mar 9 22:02:01 2004


I tried the same procedure while omitting step 2. This time the program appears 
to be loading, but the gui does not appear. The only message that appears on the
screen indicates the database is loading. After five minutes, the program has
still not loaded.


-----Original Message-----
From: Kyle McDonald - Eagle CAD [mailto:Kyle.McDonald "at" Sun.COM]
Sent: Tuesday, March 09, 2004 4:07 PM
To: Kaplan, Andrew H.
Cc: vnc-list "at" realvnc.com
Subject: Re: Setenv Variables on a VNC Session


Kaplan, Andrew H. wrote:
> I am trying to get a particular program to run via a VNC connection, but am
> currently unable to do so. The program does run 
> when invoked via a Hummingbird client connection. Here is the procedure that
> works on the Hummingbird connection and I 
> am trying to get to work on the VNC:
> 
> 1. Connect to the remote client via a telnet session.
> 2. Type setenv DISPLAY <ip address>:0.0
> 3. Type setenv FOCUS /FOCUS
> 4. /usr/tools/cms/bin/focus_data_center
> 
> The above procedure works fine via Hummingbird, but not so with VNC. Anyone
have
> insight into this? Thanks. 

Try skipping step 2 in the VNC session.

DISPLAY should already be set to the right value. You shouldn't
need to set it again. Also <ipaddress>:0.0 is likely the wrong
value if you want it to run in VNC.

If this still doesn't work, you'll have to post more details,
like the error messages you get when running the application.

	-Kyle

-- 
                                    _
-------------------------------ooO( )Ooo-------------------------------
Kyle J. McDonald                 (o o)         Systems Support Engineer
Sun Microsystems Inc.            |||||
Enterprise Server Products                        Kyle.McDonald "at" Sun.COM
1 Network Drive BUR03-4630       \\\//          voice:   (781) 442-2184
Burlington, MA 01803             (o o)            fax:   (781) 442-1542
-------------------------------ooO(_)Ooo-------------------------------