remote port forwarding and vnc

mneevens@xs4all.nl mneevens "at" xs4all.nl
Sat Jan 24 12:20:00 2004


Hi All,

I just started to play with vnc, but I do have
experience with remote port forwarding with ssh.
This is the problem I encountered:

At work, behind my employers firewall, I run the vnc server
(on windows 2000) on the standard 5900 port. I then use
a ssh client to connect to my linux machine at home, therebye
forwarding the remote port 5900 to the local port 5900 :
"ssh -l root -R:5900:localhost:5900 my.machine.at.home",

When at home, I run the vncviewer (for Linux), I expected to get
my desktop at work when doing "vncviewer localhost", but the vncviewer
stops and says, "local loopback connections are disabled".

I guess my port forwarding is not the problem: when I try to telnet
to localhost 5900, I get a response:

> telnet localhost 5900
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
RFB 003.003

The vncviewer seems to prevent users from connecting
to a server that runs on the same machine (because
it doesn't make sense to do that), but in my case
it does make sense, because I forwarded the port to
(the same portnumber on) the machine at work.

What am I doing wrong?
I would very much appreciate suggestions or help.

Thanks
Marijn