vncserver no longer active after unix session logout

Joel Lieberman joel.lieberman "at" verizon.net
Mon Jan 12 13:19:01 2004


Corne -

Sorry I can't get the accent over the
'e' in your name.
I tried running the vncserver with the
'at' command as:

$ at now
nohup vncserver -geometry 1024x768 &
^D

This seems to have fixed the problem
with vncserver after logout on Solaris
(Intel).

Thanks very much!  Perhaps the Real
VNC-Group admin can make a reference to
this elegant solution in the FAQs
for those people who have problems with
running VNC in a Solaris (Intel)
environment.

It is such a simple workaround!

Cheers -

Joel Lieberman

-----Original Message-----
From: Joel Lieberman
[mailto:joel.lieberman "at" verizon.net]
Sent: Monday, January 12, 2004 7:32 AM
To: Corne Beerse
Subject: RE: vncserver no longer active
after unix session logout

Corne  -

Thanks very much!  I'll check it out.

Joel
-----Original Message-----
From: Corne Beerse
[mailto:cbeerse "at" lycos.nl]
Sent: Monday, January 12, 2004 5:46 AM
To: Joel Lieberman
Subject: Re: vncserver no longer active
after unix session logout

Joel Lieberman wrote:

> Greetings -
>
> I posted this problem some time ago
and whilst a number of people tried to
> help, it was never resolved.  I would
like to try again to solve the problem.
>
>
> I am using vncserver version 3.3.6 on
Solaris 8 (Intel).  If I log onto the
> unix box at the console or via a
telnet session and start a vncserver, I
can
> successfully connect to the vncserver
with the vncviewer from some arbitrary
> client box.  The connection works
properly and the Solaris desktop is
> displayed correctly.
>
> Problem:  when I logout of the Unix
session (as Unix account) either at the
> console or from the telnet session
that started the vncserver, the
vncserver
> is no longer accessible in a correct
manner.  This means that I can connect
> to the vncserver (the process is still
alive) but the display is a gray
> screen and no vncviewer controls are
active. The session (vnc client) is
> essentially dead.

That's a setting sometimes found on some
unix machines. It's the default cleanup
of potentially hanging and/or stopped
jobs. There are some ways ot around
that.
Most times I use the `batch` command (or
`at now`) to start programs that need
to run beyond the current loggin. See
`man batch` or `man at` for details.
`batch vncserver`

For vnc, I prefer the setup as on
http://www.sourcecodecorner.com/articles
/vnc/linux.asp , no need to login to
start vncserver...

>
> I have tried to start the vncserver
with an '&' and a 'nohup' command to run
> it as background and detached, but the
results are the same.  As soon as I
> log out of the Unix session itself,
the vncserver process stays alive, but
> the functionality is gone.
>
> One last thing:  When I have used the
same vncserver version on either Linux
> (SuSE or Red Hat) or Solaris (SPARC),
I have never had this problem. The
> Solaris (Intel) box with the problem
is a plain-vanilla installation that
> behaves normally otherwise.
>
> Any help would be appreciated.
>
> Thanks - Joel
________________________________________
_______ VNC-List
> mailing list VNC-List "at" realvnc.com To
remove yourself from the list visit:
>
http://www.realvnc.com/mailman/listinfo/
vnc-list