vncserver no longer active after unix session logout

Joel Lieberman joel.lieberman "at" verizon.net
Sun Jan 11 13:33:00 2004


Greetings -

I posted this problem some time ago and
whilst a number of people tried to help,
it was never resolved.  I would like to
try again to solve the problem.

I am using vncserver version 3.3.6 on
Solaris 8 (Intel).  If I log onto the
unix box at the console or via a telnet
session and start a vncserver, I can
successfully connect to the vncserver
with the vncviewer from some arbitrary
client box.  The connection works
properly and the Solaris desktop is
displayed correctly.

Problem:  when I logout of the Unix
session (as Unix account) either at the
console or from the telnet session that
started the vncserver, the vncserver is
no longer accessible in a correct
manner.  This means that I can connect
to the vncserver (the process is still
alive) but the display is a gray screen
and no vncviewer controls are active.
The session (vnc client) is essentially
dead.

I have tried to start the vncserver with
an '&' and a 'nohup' command to run it
as background and detached, but the
results are the same.  As soon as I log
out of the Unix session itself, the
vncserver process stays alive, but the
functionality is gone.

One last thing:  When I have used the
same vncserver version on either Linux
(SuSE or Red Hat) or Solaris (SPARC), I
have never had this problem.
The Solaris (Intel) box with the problem
is a plain-vanilla installation that
behaves normally otherwise.

Any help would be appreciated.

Thanks -
Joel