Xvnc: error while loading shared libraries: libstdc++-libc6.2-2.so.3

William Hooper whooper "at" freeshell.org
Sat Jan 10 15:53:00 2004


arib "at" hi.is said:
> Hi everyone,
>
> Im having trouble installing vnc on my rh9 box.
>
> I have tried to rpm the libstdc .. package but it keeps telling me its
> already installed

The RPMs from the RealVNC site are for RH 7.3, so you need the
compat-libstdc++ RPM installed.

[whooper "at" butters whooper]$ whichcd -vRHL9 compat-libstdc++
Searching in the RHL9 database.
Searching for compat-libstdc++...

CD-1:compat-libstdc++-7.3-2.96.118.i386.rpm
CD-1:compat-libstdc++-devel-7.3-2.96.118.i386.rpm

> so i forced installing vnc-3.3.7-1.i386.rpm with rpm
> -ivh vnc-3.3.7-1.i386.rpm --nodeps --force, because it kept telling me
> that libstdc.. package was needed for installing vnc.

You probably should have listened.  Using --nodeps is almost never a good
idea.

-- 
William Hooper