Error reading protocol version

Seak, Teng-Fong tfseak "at" futurmaster.com
Wed Apr 28 15:39:01 2004


	Ah ha!  Are you sure VNC is listening in 5900 as you expected?  Check it first.  Well, I don't know what packet sniffer you're using, but could you use other tool to check this out?

	And as I've asked, is the port forwarding points to the correct machine?  I mean, eg, it's forwarding to something like 192.168.0.124 while your machine is 192.168.0.125 and you just missed that little bit!

	On the other hand, what's the brand mark of the firewall?  Because you said '0' are returned.  That recalls me something similar: Cisco firewall returns '*' on translation.  It's a sort of filter.  Well, I think.

	Could you use VPN client through your office firewall?

> -----Message d'origine-----
> De : Waszkewitz Peter (PA-ATMO/EES22) * [mailto:Peter.Waszkewitz "at" de.bosch.com]
> Envoyi : mercredi 28 avril 2004 15:58
> @ : vnc-list "at" realvnc.com
> Objet : Re: Error reading protocol version
> 
> No, I don't get the password dialog since client and server never agree on the protocol.
> 
> I will check the firewall issue (different department, large company :-).
> 
> Trying a different NIC on the server is one of the next items on my list, although I am
> hoping to avoid it, as the machine would have to be reconfigured by on-site personnel on
> the other side of the world.
> 
> Thanks
> 
> Peter Waszkewitz
> 
> Subject: RE: Error reading protocol version
> Date: Tue, 27 Apr 2004 17:35:52 +0200
> From: "Seak, Teng-Fong" <tfseak "at" futurmaster.com>
> To: <vnc-list "at" realvnc.com>
> 
> 	Did you get the password dialog?
> 
> 	The port is open in the firewall, but is it forwarded?  Or is it forwarded to the correct
> internal address?
> 
> 	You've tried three diff. NIC for client, but have you tried diff. NIC for server?
> 
> > -----Message d'origine-----
> > De : Waszkewitz Peter (PA-ATMO/EES22) * [mailto:Peter.Waszkewitz "at" de.bosch.com]
> > Envoyi : mardi 27 avril 2004 15:23
> > @ : vnc-list "at" realvnc.com
> > Objet : Error reading protocol version
> >
> > Trying to connect to a VNC server on a Win2K system through a firewall (over
> > which I do not have any control) I receive an "error reading protocol version"
> > message. A packet sniffer shows me that there is a connection established, but
> > instead of the protocol version RBF something only some 0s are returned.
> >
> > The firewall is open for the two IP addresses in question on port 5900. I
> > tried
> >
> > 	telnet IP-address-of-server 5900
> >
> > and it does connect but echoes nothing (not exactly surprising, considering
> > the 0s). telnet on other ports rightly refuses connection.
> >
> > I have tested various scenarios with other machines (blank password, different
> > default and user passwords, ...) and have not seen this behavior. The packet
> > sniffer does not show any other port on the server being used than 5900. I
> > have tried two different machines with three different network cards as client
> > and always have the same effect.
> >
> > Does anyone have an idea what may cause this behavior?
> >
> > Peter Waszkewitz
> _______________________________________________
> VNC-List mailing list
> VNC-List "at" realvnc.com
> To remove yourself from the list visit:
> http://www.realvnc.com/mailman/listinfo/vnc-list