Error reading protocol version

Seak, Teng-Fong tfseak "at" futurmaster.com
Tue Apr 27 16:37:01 2004


	Did you get the password dialog?

	The port is open in the firewall, but is it forwarded?  Or is it forwarded to the correct internal address?

	You've tried three diff. NIC for client, but have you tried diff. NIC for server?

> -----Message d'origine-----
> De : Waszkewitz Peter (PA-ATMO/EES22) * [mailto:Peter.Waszkewitz "at" de.bosch.com]
> Envoyi : mardi 27 avril 2004 15:23
> @ : vnc-list "at" realvnc.com
> Objet : Error reading protocol version
> 
> Trying to connect to a VNC server on a Win2K system through a firewall (over
> which I do not have any control) I receive an "error reading protocol version"
> message. A packet sniffer shows me that there is a connection established, but
> instead of the protocol version RBF something only some 0s are returned.
> 
> The firewall is open for the two IP addresses in question on port 5900. I
> tried
> 
> 	telnet IP-address-of-server 5900
> 
> and it does connect but echoes nothing (not exactly surprising, considering
> the 0s). telnet on other ports rightly refuses connection.
> 
> I have tested various scenarios with other machines (blank password, different
> default and user passwords, ...) and have not seen this behavior. The packet
> sniffer does not show any other port on the server being used than 5900. I
> have tried two different machines with three different network cards as client
> and always have the same effect.
> 
> Does anyone have an idea what may cause this behavior?
> 
> Peter Waszkewitz