VNC Server on Redhat ES 3.0-blank screen w/ cursor for Gnome

Chris Riffle criffus "at" yahoo.com
Sat Apr 24 17:14:01 2004


Hello-
(sorry if this has already been hashed out in another thread -- )

I am trying to get VNC running on a RH ES 3.0 (fresh install) box that will
get me to a Gnome session.
I'm able to get it to work using twm, but when I alter my /.vnc/xstartup
file to start w/ Gnome, I get a blank (almost black) screen with a cursor.
I wait and wait for Gnome- but all I can do is move a cursor around and do
nothing else.

Can anybody point me in the right direction here? (I'm fairly new to Gnome
and X, as we've only run Linux for DNS servers mainly, w/ no GUI...)

* I have done the following so far:
-Installed with OS: vnc-4.0-0.beta4.1.1
-altered /etc/X11/xdm/Xaccess (saved Xaccess.orig)--uncommented "any host
can get a login window".
-altered /etc/X11/gdm/gdm.conf (saved gdm.conf.bak) --set [xdmcp]
Enable=true
**I don't know if those steps were actually necessary**

Thanks for any help!
-Chris



Below is a bunch of info including my xstartup file and some logs:

Here's how it goes for me:
***********************************************************************
[chris "at" s02 .vnc]$ vncserver

New 's02.intranet.aionent.net:1 (chris)' desktop is
s02.intranet.aionent.net:1

Starting applications specified in /home/chris/.vnc/xstartup
Log file is /home/chris/.vnc/s02.intranet.aionent.net:1.log

[chris "at" s02 .vnc]$ ps -aux | grep vnc
chris     2846  0.1  1.1  8564 5748 pts/0    S    10:03   0:00 Xvnc :1
-desktop s02.intranet.aionent.net:1 (chris) -httpd /usr/share/vnc/classes
-auth /home/chris/.Xauthority -geometry 1024x768 -depth 16 -rfbwait 30000
-rfbauth /home/chris/.vnc/passwd -rfbport 5901 -pn


*****************xstartup is:**********************************
[chris "at" s02 .vnc]$ cat ./xstartup
#!/bin/sh

# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

xrdb $HOME/.Xresources
# xsetroot -solid grey
#vncconfig -iconic &
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
gnome-start &
[chris "at" s02 .vnc]$

**************log after attempting VNC login from windows XP
box:*************************
[chris "at" s02 .vnc]$ cat ./s02.intranet.aionent.net:1.log

Xvnc version 4.0b4 - built Sep  5 2003 13:04:00
Underlying X server release 40300000, The XFree86 Project, Inc


Sat Apr 24 10:03:16 2004
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing
from list!
xrdb: No such file or directory
xrdb: can't open file '/home/chris/.Xresources'
/home/chris/.vnc/xstartup: line 11: gnome-start: command not found

Sat Apr 24 10:07:50 2004
 Connections: accepted: 192.168.0.13::3679
 SConnection: Client needs protocol version 3.3

Sat Apr 24 10:07:53 2004
 Client:      Server default pixel format depth 16 (16bpp) little-endian
rgb565
 Client:      Client pixel format depth 8 (8bpp) bgr233

Sat Apr 24 10:11:14 2004
 Connections: closed: 192.168.0.13::3679 (Clean disconnection)
 SMsgWriter:  framebuffer updates 436
 SMsgWriter:    ZRLE rects 872, bytes 21015
 SMsgWriter:    raw bytes equivalent 1018464, compression ratio 48.463669
[chris "at" s02 .vnc]$