Problem Making vnc-4.0b4-unixsrc on Solaris 8

b.schworm@unsw.edu.au b.schworm "at" unsw.edu.au
Fri Apr 2 02:40:01 2004


I have encountered the following problem making vnc-4.0b4-unixsrc on solaris 8
with gcc 3.2.1:

    making all in programs/Xserver/vnc/module...
    CC    -c  vncExtInit.cc
    *** Error code 1

Looks like a problem in the make files but I have not been able to find it. I
have tried both gnu make and ccs make with the same result.

I have tried various defines with the make command but here is my latest
attempt: 

  # make World CC=gcc MAKE=/usr/ccs/bin/make 2&>1 > makeworld.log &

and the beginning of makeworld.log is

    Building XFree86 version 4.4.0 (29 February 2004).

    Building on SunOS 5.8 Generic_108528-18 sun4u (5.8.0).

    GCC version: 3.2

The file ends with the error quoted above with a few more "Error Code 1"
messages. 

To test my setup, I compiled XFree86-4.4.0-src without any problems. 

I have compiled and installed vnc-3.3.7-unixsrc but would like to try
the beta version. I would appreciate any advice.

Thanks, Bill

___________________________________________________________________

Bill Schworm
School of Economics
University of New South Wales
Sydney, NSW, 2052
Australia