win98 user properties on startup bug?

David West djw@spyderworks.co.uk
Mon Jul 14 16:33:00 2003


More regarding the unwelcome properties dialog...

The reg file was exported from the registry from an installed and
configured version
of vnc -- that is, a default password has been set. Running vnc from the
start menu,
or from running startvnc.bat manually both work as expected. The problem
only arises
when running the login script.

Setting AllowProperties=0 brings up an error dialog saying (more or less)
that vnc
can only be configured by admin. Different values for the other entries in
the reg
file have also been tried, but no success. I also tried applying the reg
patch only
once, instead of at each login.

I'm assuming then that vnc is still asking for a password (or maybe
something else
is being requested -- like what?)

Developers: this is a design issue -- please clarify -- displaying the
properties
box is NOT the same as asking for a password!

So what is causing w98 -- but not xp -- to do this???


> When a user logs in, a login script runs which calls the following
> batch file. Why doesn't this work?
>
> :startvnc.bat - called when user logs in
> regedit /s g:\vnc.reg
> start g:\tightvnc\winvnc.exe -kill -run
>
> ---
>
> g:\vnc.reg looks like:
>
> REGEDIT4
>
> [HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3]
> " "=dword:00000000
>
> [HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\Default]
> "AllowProperties"=dword:00000001
> "AllowShutdown"=dword:00000001
> "DebugMode"=dword:00000004
> "DebugLevel"=dword:0000000a
> "DisableTrayIcon"=dword:00000000
> "Password"=hex:xx,xx,xx,xx,xx,xx,xx,xx

Thanks for giving this your attention,

d@vidwest.net
djw@spyderworks.co.uk