win98 user properties on startup bug?

David West djw@spyderworks.co.uk
Fri Jul 11 18:18:01 2003


win98 user properties on startup bug? (yes, i think it's a bug)

This is proving to be a right pain... I've tried this with
tightvnc-1.2.8_x86 and UltraVNC-107-Win32 - same result:
Current User Properties dialog at login, Click OK (with or without
entering the password), and VNC fails to start -- every time on Win98
(Bad), never on XP (Better)...

When a user logs in, a login script runs which calls the following batch
file. Why doesn't this work?

:startvnc.bat - called when user logs in
regedit /s g:\vnc.reg
start g:\tightvnc\winvnc.exe -kill -run

---

g:\vnc.reg looks like:

REGEDIT4

[HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3]
" "=dword:00000000

[HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\Default]
"AllowProperties"=dword:00000001
"AllowShutdown"=dword:00000001
"DebugMode"=dword:00000004
"DebugLevel"=dword:0000000a
"DisableTrayIcon"=dword:00000000
"Password"=hex:xx,xx,xx,xx,xx,xx,xx,xx

---

I've placed the above keys in the _only_ places thay should go -- 
according to http://www.uk.research.att.com/vnc/winvnc.html -- to quote:

"1.Local machine-specific settings. Options specified here are not
overridable. Location:
HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\

2.Local default user settings. Location:
HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\Default

3.Local per-user settings.  These override the local default user
settings. If there is no current user, the username SYSTEM will be used.
Location:
HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\<username>

4.Global per-user settings.   These are only read if AllowProperties has
not been set to zero (see below) Location:
HKEY_CURRENT_USER\Software\ORL\WinVNC3

Most options can only be specified in a subset of these places, as
specified in each option's description below..."

I understand this is a common problem -- but I can't find the solution --
please help!


Thanks for giving this your attention,

d@vidwest.net
djw@spyderworks.co.uk