Lost cursor / arrow control in dos box

Craig Bryant CBryant@healthcare-automation.com
Tue Jul 1 21:03:00 2003


Apologies to the list up front if this is a old issue.
I've gone through the last 4 months of archives and have not
seen this specific issue.  I'm still digging further back

We are using (windows) VNC Host ver. 3.3.6 and client 3.3.7
to connect 2 windows machines to each other.  If we get the
kinks worked out, the normal setup will be a win 98 box 
controlling the win2k box (home to office).

The Windows 2000 Pro box is the VNC host.  It runs an old 
FoxPro database in an MS Dos window.  The app runs fine
but we can't seem to get the arrow (left, right, up, down) or
page up / page down keys to work correctly.

I've tried all the tricks I know.  I believe it has something to
do with the way FoxPro is manipulating the screen.  In just
a plain old dos box, I can get the cursor keys to work fine
under VNC.  Once we launch the FoxPro app, the cursor
keys seem to stop functioning.

If you have any ideas or hints, I'd be really grateful.
thx
cab