"gnome-session:you're already running a session manager" Red Hat 8

J.W. Vraets jwvraets@sympatico.ca
Fri Nov 15 17:28:00 2002


I have been trying for several days now to get VNC running as a server on a
Red Hat 8 system with the intent that I can use a viewer on one of several
Windows PCs (XP, ME and 98SE) to see a GNOME environment. (Note: All Windows
based server sessions work like a charm when viewed from any machine). All
testing is being done on machines connected on a 100mbps LAN not externally
accessible. Linux box has its firewall off.

The /root/.vnc/xtartup file contents are:

---------------------------
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm
exec gnome-session &

-----------------------------
I am running as "root" on the Linux machine when I launch the server using the
command: vncserver :2

The screen messages during launch are as follows:

-----------------------------
New 'X' desktop is jetjaguar:2

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/jetjaguar:2.log
------------------------------

The viewer is started on a Win XP machine but the result is the oft mentioned
grey screen with a terminal window.

I kill the viewer session on the Win XP machine, kill the vnc server on and
look at the contents of the log file on the Linux machine which are as
follows:

----------------------------------
15/11/02 10:55:26 Xvnc version 3.3.4 - built Sep 20 2002 15:20:12
15/11/02 10:55:26 Copyright (C) 2002 RealVNC Ltd.
15/11/02 10:55:26 Copyright (C) 1994-2000 AT&T Laboratories Cambridge.
15/11/02 10:55:26 All Rights Reserved.
15/11/02 10:55:26 See http://www.realvnc.com for information on VNC
15/11/02 10:55:26 Desktop name 'X' (jetjaguar:2)
15/11/02 10:55:26 Protocol version supported 3.3
15/11/02 10:55:26 Listening for VNC connections on TCP port 5902
15/11/02 10:55:27 Listening for HTTP connections on TCP port 5802
15/11/02 10:55:27   URL http://jetjaguar:5802
gnome-session: you're already running a session manager

15/11/02 10:56:12 Got connection from client 192.168.2.60
15/11/02 10:56:12 Protocol version 3.3
15/11/02 10:56:17 Pixel format for client 192.168.2.60:
15/11/02 10:56:17   8 bpp, depth 8
15/11/02 10:56:17   true colour: max r 7 g 7 b 3, shift r 0 g 3 b 6
15/11/02 10:56:17 Using ZRLE encoding for client 192.168.2.60
15/11/02 10:56:30 Client 192.168.2.60 gone
15/11/02 10:56:30 Statistics:
15/11/02 10:56:30   key events received 0, pointer events 106
15/11/02 10:56:30   framebuffer updates 109, rectangles 316, bytes 9208
15/11/02 10:56:30     ZRLE rectangles 316, bytes 9208
15/11/02 10:56:30   raw bytes equivalent 830382, compression ratio 90.180495

------------------------------------------

I have tried variations of the gnome-session command with and without "exec"
and with and without the "&" but the  results are the same. I have read the
numerous "grey screen" related comments (and tried to comment out the
"xsetroot..." and the "xterm ..." lines in the xstartup script but nothing I
do brings up the GNOME environment in the viewer window. The problem I suspect
is related to the line in the log "gnome-session: you're already running a
session manager". However, I have no idea how to handle this (or I could be
all wrong and it is something else).

Having beat my head against a brick wall this long has not proved fruitful.
Can anyone who has succeeded in getting this working please get in touch with
me and tell my what I am not getting? Help would be very much appreciated.

J.W. Vraets
Grimsby, Ontario - CANADA