3.3.5 Problems starting server on Sun

Kevin Minney kminney@cadence.com
Tue Nov 12 17:02:01 2002


Hi,

The machine is running Solaris7, infact I see the same problem on both machines which I tried ..

1) Sun Ultra60, Solaris7 (u60pks..)
2) Sun SunBlade1000, Solaris8

On both machines the old version of the vnc server (3.3.3r2) works fine with exactly the same setup.


There is no X11 lock file in /tmp, I have checked for that. I do not have root permissions, I have tried in the past to get out IT department to open up permissions on this area but they refuse.

I will try to get IT to start the server for me as root, they shouldn't have a problem doing that,

thanks,

Kevin


-----Original Message-----
From: "Beerse, Corni" [mailto:c.beerse@torex-hiscom.nl] 
Sent: Tuesday, November 12, 2002 4:57 AM
To: 'vnc-list@realvnc.com'
Subject: RE: 3.3.5 Problems starting server on Sun


> -----Original Message-----
> From: Kevin Minney [mailto:kminney@cadence.com]
> after using VNC for about a year I noticed that a new version has been 
> released (3.3.5), so I decided to give it a try ..
> 
> I can't seem to start the server on my Sun machine, if I
> check the logfile in the .vnc directory I see ..
> 
> 
> 11/11/02 16:45:42 Xvnc version 3.3.5 - built Nov  1 2002 10:18:33 
> 11/11/02 16:45:42 Copyright (C) 2002 RealVNC Ltd. 11/11/02 16:45:42 
> Copyright (C) 1994-2000 AT&T Laboratories Cambridge. 11/11/02 16:45:42 
> All Rights Reserved. 11/11/02 16:45:42 See http://www.realvnc.com for 
> information on VNC 11/11/02 16:45:42 Desktop name 'X' (u60pks91:6)
> 11/11/02 16:45:42 Protocol version supported 3.3
> 11/11/02 16:45:42 Listening for VNC connections on TCP port 5906
> 11/11/02 16:45:42 Listening for HTTP connections on TCP port 5806
> 11/11/02 16:45:42   URL http://u60pks91:5806
> 
> Fatal server error:
> Couldn't add screen
> xrdb: Interrupted system call
> xrdb: Can't open display 'u60pks91:6'
> xsetroot:  unable to open display 'u60pks91:6'

Wild guess, your machine is named u60pks91...

For SunOS, I think on 2 problems: one is the X11 lock in /tmp/.... Since the version 3.3.3 runs, that should not be the problem. That leaves only 1 general problem: Version 3.3.5 is rated at a higher SunOS version than the 3.3.3 version. What version of SunOS are you running? `uname -a` will show it to you. Check that with the info with the new release.

> 
> 
> 
> And here is what my xstartup file looks like ..
> 
> 
> #!/bin/sh
> 
> xrdb $HOME/.Xresources
> xsetroot -solid grey
> #xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" & #dtwm 
> & /usr/dt/bin/Xsession &

If this works with the previous vnc version, it should still work.

> And this is how I am trying to start the server ..
> 
> 
> ./vnc-3.3.5-sparc_solaris_2.5/vncserver :6 -alwaysshared -cc
> 3 -nolisten local
> -geometry 1280x1024 &

Do you use Solaris 2.5 (or upwards?) (and do you use it on sparc hardware?)

> I have had no problem starting VNC up till now, the above
> xstartup file has
> worked ok for the previous version I have been using 
> (3.3.3r2). I have tried a
> few different things, including clearing out my .vnc 
> directory and letting vnc
> create a default xtartup file but the server still fails to start up,
> 
> can anyone suggest what might be wrong?

Where there no other changes? What if you run vncserver ( or Xvnc) as user "root"? If that works, then I guess the X11 lock problem was solved by making Xvnc running as setuid root. (`chown root /path/to/Xvnc; chmod u+s
/path/to/Xvnc`)


CBee
_______________________________________________
VNC-List mailing list
VNC-List@realvnc.com http://www.realvnc.com/mailman/listinfo/vnc-list