3.3.5 Problems starting server on Sun

Kevin Minney kminney@cadence.com
Tue Nov 12 01:01:01 2002


Hi,

after using VNC for about a year I noticed that a new version has been
released (3.3.5), so I decided to give it a try ..

I can't seem to start the server on my Sun machine, if I check the logfile in
the .vnc directory I see ..


11/11/02 16:45:42 Xvnc version 3.3.5 - built Nov  1 2002 10:18:33
11/11/02 16:45:42 Copyright (C) 2002 RealVNC Ltd.
11/11/02 16:45:42 Copyright (C) 1994-2000 AT&T Laboratories Cambridge.
11/11/02 16:45:42 All Rights Reserved.
11/11/02 16:45:42 See http://www.realvnc.com for information on VNC
11/11/02 16:45:42 Desktop name 'X' (u60pks91:6)
11/11/02 16:45:42 Protocol version supported 3.3
11/11/02 16:45:42 Listening for VNC connections on TCP port 5906
11/11/02 16:45:42 Listening for HTTP connections on TCP port 5806
11/11/02 16:45:42   URL http://u60pks91:5806

Fatal server error:
Couldn't add screen
xrdb: Interrupted system call
xrdb: Can't open display 'u60pks91:6'
xsetroot:  unable to open display 'u60pks91:6'



And here is what my xstartup file looks like ..


#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#dtwm &
/usr/dt/bin/Xsession &



And this is how I am trying to start the server ..


./vnc-3.3.5-sparc_solaris_2.5/vncserver :6 -alwaysshared -cc 3 -nolisten local
-geometry 1280x1024 &




I have had no problem starting VNC up till now, the above xstartup file has
worked ok for the previous version I have been using (3.3.3r2). I have tried a
few different things, including clearing out my .vnc directory and letting vnc
create a default xtartup file but the server still fails to start up,

can anyone suggest what might be wrong?

thanks,

Kevin