starting multiple vncservers at bootup on solaris

Jerry Westrick jerry@westrick.com
Wed Nov 6 23:55:01 2002


why don't you try to connect locally first...

use "vncviewer localhost:71" on the server...

This way you avoid tcp/ip and network problems

once that works then procede to try remote...


On Thu, 2002-11-07 at 00:17, Morrison Davis wrote:
> I tried adding the following to services
> vnc-640x480x24  5970/tcp
> vnc-800x600x24  5971/tcp
> vnc-1024x768x24 5972/tcp
> vnc-1280x1024x24        5973/tcp
> vnc-1600x1200x24        5974/tcp
> then
> I added the following to inetd.conf
> vnc-640x480x24 stream tcp nowait bin /usr/local/bin/Xvnc Xvnc -inetd -query
> localhost -once -geometry 640x480 -depth 24 -fp tcp/localhost:7100
> vnc-800x600x24 stream tcp nowait bin /usr/local/bin/Xvnc Xvnc -inetd -query
> localhost -once -geometry 800x600 -depth 24 -fp tcp/localhost:7100
> vnc-1024x768x24 stream tcp nowait bin /usr/local/bin/Xvnc Xvnc -inetd -query
> localhost -once -geometry 1024x768 -depth 24 -fp tcp/localhost:7100
> vnc-1280x1024x24 stream tcp nowait bin /usr/local/bin/Xvnc Xvnc -inetd -query
> localhost -once -geometry 1280x1024 -depth 24 -fp tcp/localhost:7100
> vnc-1600x1200x24 stream tcp nowait bin /usr/local/bin/Xvnc Xvnc -inetd -query
> localhost -once -geometry 1600x1200 -depth 24 -fp tcp/localhost:7100
>  rebooted system
> 
> went to remote system And tried to start viewer
> I get no error and no vncsession coming up on that system.
> 
> I did figure out the _XSERVE errors if I run the Xvnc :4 -query localhost as
> root
> it does work so maybe I can just create my on startup script to be run at boot
> time
> rather than the inetd stuff, although that would be nice because then I know it
> will shutdown properly at shutdown.
> 
> "Beerse, Corni" wrote: