VNC Viewer under Solaris does not pass ctrl + mouse keys to host???

Andrew Ward award "at" cisco.com
Wed, 20 Mar 2002 15:28:00 +0000


Thanks Fred,

I might try the tight VNC just to see what happens. 

The funny thing is that the viewer with the problem is running on the
same machine as the server and when I access the window manager
directly (fvwm2) there are no probs.

Anyway thanls for your input. I hope you got in some skating on the
Rideau this year, but I hear Winterlude was pretty short.


Regards

-Andrew Ward


On Wed, Mar 20, 2002 at 02:47:12AM -0500, Fred wrote:
> I run vncviewer and server on solaris 8, sometimes on the
> same host.  Sometimes in fullscreen mode, sometimes not,
> sometimes with the viewer under twm, sometimes no
> windowing system.
> 
> Never had a problem with ALT-mousebutton
> or Ctrl-Mousebutton.  Maybe that key/button combination
> has special meaning for the windowing system of which
> vncviewer is a client; maybe the windowing system is
> intercepting them?
> 
> Fred
> --------------------------------------------------------------------------
> Fred Ma
> Department of Electronics
> Carleton University, Mackenzie Building
> 1125 Colonel By Drive
> Ottawa, Ontario
> Canada     K1S 5B6
> fma "at" doe.carleton.ca
> ==========================================================================
> 
> > Date: Tue, 19 Mar 2002 15:27:41 -0800
> > From: Andrew Ward <award "at" cisco.com>
> > Subject: VNC Viewer under Solaris does not pass ctrl + mouse keys to host???
> >
> > When I run VNCviewer on my solaris box (SunOS award-u10 5.8
> > Generic_108528-07 sun4u sparc SUNW,Ultra-5_10), I CANNOT access any
> > Xterm menus (ctrl+leftMouse or ctrl+middleiMouse or ctrl +
> > rightMouse).
> >
> > When I launch VNCViewer from a PC, I have FULL access to these menus.
> >
> > When I access those menus directly on xterms launched on that Solaris
> > box (not through VNC server / viewer) I ALSO HAVE FULL access to these
> > menus.
> >
> > I am using ~award/vnc_sun4_sosV_5.5/Vncviewer.  (The troubled viewer
> > and host are running on the same machine.) It has been working fine up
> > until ECS pushed Solaris 8 on top of me. Since then it has been bad.
> >
> > And, I DO start my vnc server with:
> >
> > vncserver -pn -depth 24 -alwaysshared -geometry 1152x900 ; autocutsel
> >
> > Any insights would be greatly appreciated.
> >
> > - -Andrew
> >
> > - ------------------------------------------------------------
> >     Andrew Ward
> > ph: 408 527-2773                        |           |
> >     800.250.4800 ext 72773              |           |
> > Internet POP Systems BU                |||         |||
> > GSR development group (12000)     ..:|||||||:...:|||||||:..
> > email to: award "at" cisco.com         C i s c o   S y s t e m s
> ---------------------------------------------------------------------
> To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
> 'unsubscribe vnc-list' in the message BODY
> See also: http://www.uk.research.att.com/vnc/intouch.html
> ---------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------