-inetd option with RH7.2

Brian Turner bturner6 "at" bigpond.net.au
Tue, 05 Mar 2002 09:50:24 +0000


I am having trouble getting vnc to work with the -inetd option and would
appreciate some assistance.  I am a relative newbie so your patience is
appreciated.  I have searched the archives for several hours before this.

I have a fresh installation of RH7.2 (also tried RH7.1), using KDE 2.2.
Starting vncserver from the console works fine.  Between old archive entries
and Jeff Vencent's faq on sourcecodecorner.com I have tried to setup Xvnc from
xinetd.

I only get a grey screen on the viewer (no login/password), which Jeff seems
to indicate should be a problem with xdmcp.  I checked UDP port 177 with nmap
as suggested and it's closed so I guess that's the problem.

I have changed these 2x lines in kdmrc (previously commented out):
[Xdmcp]
Enable=true
Port=177

and for Xaccess I uncommented one line to read:
any host can get a login windows

previously '#*                #any host can get a login window'

Also commented out 'DisplayManager.requestPort: 0' in xdm-config.
All other lines the original defaults supplied with RH7.2 apart from the new
entries in services and xinetd.

What have I missed?

Thks & Rgds
Brian Turner
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------