Loading Initial Screen then disconnects

Alex Angelopoulos alex "at" bittnet.com
Thu, 31 Jan 2002 20:48:40 +0000


It sounds like the issue is definitely involved with an implementation
difference between client and server.

I've noticed a couple of flukes that can happen with dumber NICs
(particularly speed sensing ones) and speed-matching switches, also. It
seeks NICs will automatically negotiate 100 MiBPS  speeds based on cable
type and system they are talking to without paying any attention to
whether the singal coming through is noisy.  If the NIC switchout
doesn't fix it and the thing is running at 100MiBPS, you may want to
also shut it down to 10 MiBPS.

I don't think that's the problem though- 90% of the time if it
negotiates too high a speed, communication fails before you even got to
network logon, let alone to a condition where you can run VNCViewer.

----- Original Message -----
From: "Jerry Turnbow" <jwt "at" slme.com>
To: <vnc-list "at" uk.research.att.com>
Sent: Thursday/2002 January 31 15:28
Subject: RE: Loading Initial Screen then disconnects


: Alex - we applied the patches, ala Win95 service pack 2 to no avail.
: It's interesting that this machine can control others just fine.  I
: looked at the diagnostics on my network switch and noticed a high
number
: of CRC errors when we try to remote connect to this PC.  Changing the
: cable and switch port made no difference, so I'm beginning to suspect
: the NIC has a problem under the high traffic generated by VNC.  We're
: replacing the NIC now to see what happens.
:
: Thanks - I'll keep you posted so others might benefit if this turns
out
: to be the cure.
:
: - JWT
:
: -----Original Message-----
: From: owner-vnc-list "at" uk.research.att.com
: [mailto:owner-vnc-list "at" uk.research.att.com] On Behalf Of Alex
: Angelopoulos
: Sent: Thursday, January 31, 2002 12:27 PM
: To: vnc-list "at" uk.research.att.com
: Subject: Re: Loading Initial Screen then disconnects
:
:
: Two thoughts here.
:
: (1) Probably not important now, but - Could you confirm that this is
: happening with both the Windows and the Java viewer when connecting to
: the Win95 system as a server? Sometimes there is a difference in
: connection capability.
:
: (2) Since it is Win95, it's possible that it has a problem with an
: unpatched TCPIP stack. In fact, I lean more towards that as a possible
: cause of the problem since you can get basic connectivity by
telneting.
: Obviously the server is up and running; it may just get suddenly
: overwhelmed when you try to do a full VNC connection to that port.
You
: may want to confirm that you have all of the Microsoft recommended
: TCP/IP patches on the 95 machine.
:
: Since it's a pain to get downloads for Win95 if you haven't tried on
the
: Microsoft site lately, here's a couple of things that may help (if
: you're lucky you know a better way to get ot the stuff than this) -
Try
: http://download.microsoft.com If you use Win95 as the OS, then do a
: keyword search of the archived content for TCP and QFE, you should
find
: the TCPIP update files and the Win95 hotfix checker (that's the QFE
tool
: if you're not aware of it).
:
: I hope that's the actual source of the problem.  There ARE known
issues
: on unpatched Win95 with ICMP packets and weird fragmetns it may
: interpret as ICMP.  There's also a huge memory leak in the original
: TCPIP stack.
:
:
: ----- Original Message -----
: From: "Jerry Turnbow" <jwt "at" slme.com>
: To: <vnc-list "at" uk.research.att.com>
: Sent: Thursday/2002 January 31 12:54
: Subject: RE: Loading Initial Screen then disconnects
:
:
: : Alex - tried it. It does respond with that prompt when telnet-ing to
: : port 5900, so it appears the server is running.
: :
: : FYI, I can run VNC from the Win95 machine and connect to the NT 4.0
: : workstation just fine.  In only fails when trying to connect from
the
: NT
: : 4.0 station.
: :
: : - JWT
: :
: : -----Original Message-----
: : From: owner-vnc-list "at" uk.research.att.com
: : [mailto:owner-vnc-list "at" uk.research.att.com] On Behalf Of Alex
: : Angelopoulos
: : Sent: Thursday, January 31, 2002 11:11 AM
: : To: vnc-list "at" uk.research.att.com
: : Subject: Re: Loading Initial Screen then disconnects
: :
: :
: : Sounds like you're using the Java applet.  I assume you are
connecting
: : to port 5800 (which switches you over to 5900 once you have the
: applet).
: : If you try connecting to 5900 with the VNCViewer executable instead,
: : does it connect? If not, you can verify whether the server is
: answering
: : by telneting to port 5900.  You should get a message echoed back
that
: : says
: :
: : "RFB 003.003"
: :
: : If this doesn't work, either the server is not running or port 5900
is
: : blocked between you and the system..
: :
: :
: : ----- Original Message -----
: : From: "Jerry Turnbow" <jwt "at" slme.com>
: : To: <vnc-list "at" uk.research.att.com>
: : Sent: Thursday/2002 January 31 11:53
: : Subject: Loading Initial Screen then disconnects
: :
: :
: : : Hi, folks.
: : :
: : : I'm a new user to the VNC mail list.  We've been using VNC for
some
: : time
: : : to remotely administer PC's over our LAN and WAN connecting our
: : : facilities, mostly with Win95, Win95b and NT 4.0 workstations.
Most
: : : have had no problems at all, but I have one machine (a Win95 box)
: that
: : : when I try to access it from my desktop (NT 4.0 Workstation), I
get
: : the
: : : message "Please wait - loading initial screen", but no response.
: : : Eventually the connection times out and disconnects.
: : :
: : : I've pored over the mail archives for several hours but have been
: : unable
: : : to find a "fix" for this particular problem.  TCP/IP is running,
and
: : : there are no routers, VPN's, proxies, or other items between the
two
: : : systems.
: : :
: : : Any ideas???
: : :
: : : - Jerry Turnbow
: : :   SLM Electronics
: :
:
: ---------------------------------------------------------------------
: : : To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: : : 'unsubscribe vnc-list' in the message BODY
: : : See also: http://www.uk.research.att.com/vnc/intouch.html
: :
:
: ---------------------------------------------------------------------
:
: ---------------------------------------------------------------------
: : To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: : 'unsubscribe vnc-list' in the message BODY See also:
: : http://www.uk.research.att.com/vnc/intouch.html
:
: ---------------------------------------------------------------------
:
: ---------------------------------------------------------------------
: : To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: : 'unsubscribe vnc-list' in the message BODY
: : See also: http://www.uk.research.att.com/vnc/intouch.html
:
: ---------------------------------------------------------------------
: ---------------------------------------------------------------------
: To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: 'unsubscribe vnc-list' in the message BODY See also:
: http://www.uk.research.att.com/vnc/intouch.html
: ---------------------------------------------------------------------
: ---------------------------------------------------------------------
: To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: 'unsubscribe vnc-list' in the message BODY
: See also: http://www.uk.research.att.com/vnc/intouch.html
: ---------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------