ConnectPriority - Registry info

Alex Angelopoulos alex "at" bittnet.com
Thu, 24 Jan 2002 15:54:02 +0000


I still see the exact same results throughout my testing.

I experimented with the following settings for the DWORD ConnectPriority
value: 0,1,2,3 (just in case there was something incorrect in the docs).

When using "1" I am able to successfully do connection sharing.

For any other value, I always have the first connection dropped when the
2nd one attempts to connect.  Can anyone shed some light on this?

I have found some references to -shared and -noshared switches in the
archives, but nothing that documents exact usage requirements - and I
have been unable to make any use of those switches work.  Note that one
combination I have *not* tried is to have the 2nd connecting client use
the -noshared switch; requiring this seems to defeat the purpose anyway.

----- Original Message -----
From: "Tracy Millar" <tmillar "at" idrc.ca>
To: <vnc-list "at" uk.research.att.com>
Sent: Thursday/2002 January 24 10:08
Subject: Re: ConnectPriority - Registry info


: Hi there,
:
: I actually made the changes on my server to reflect what Alex has and
still
: the same results, the VNC server connection gets dumped when a second
: connection is attempted.
:
: Tracy
:
: ---------- Original Text ----------
:
: From: "Alex Angelopoulos" <alex "at" bittnet.com>, on 2002/01/23 1:23 PM:
: To: iSMTP "at" HQNT11@Servers[<vnc-list "at" uk.research.att.com>],Tracy
Millar "at" MIS
: SIG "at" IDRC CRDI
:
: COMPARISON OF REGISTRY VALUES
:
: (SUMMARY NOTE: Tracy is having an issue with having a VNC server
connection
: dumped when someone else connects to the same system.
: She has, as can be seen, created the ConnectPriority DWORD with a
value of
: "2", restarted the server, etc.)
:
: Just a quick note - I am going to try checking this out on my system,
but I
: did a quick check on the registry values.  The only
: differences in our setups were the following values:
:
: "AutoPortSelect" - mine was 1 as opposed to your "0" - but see next
item
: "PortNumber" - you had this which I didn't, but yours is set to
0x170c(5900),
: the default
: "IdleTimeout" - Yours is "0"; I didn't have this setting
: "ConnectPriority" - I had this set to "1"from checking your problem
last
: week, and I *did* connect successfully from 2 locations
: simultaneously.
:
:
:
:
:
: ---- Original Message -----
: From: "Tracy Millar" <tmillar "at" idrc.ca>
: To: <vnc-list "at" uk.research.att.com>
: Sent: Wednesday/2002 January 23 12:38
: Subject: Re: ConnectPriority - Registry info
:
:
: : As requested, here are the registry files as per below...
: :
: : *********
: : REGEDIT4
: :
: : [HKEY_CURRENT_USER\Software\ORL\WinVNC3]
: : "SocketConnect"=dword:00000001
:
: : "AutoPortSelect"=dword:00000000
: Mine is 1; obviously you have a custom port setting
:
: : "PortNumber"=dword:0000170c
: Which is here...and is set to 5900 manually
:
: : "InputsEnabled"=dword:00000001
: : "LocalInputsDisabled"=dword:00000000
:
: : "IdleTimeout"=dword:00000000
: I don't even have this
:
: : "QuerySetting"=dword:00000002
: : "QueryTimeout"=dword:0000000a
: : "PollUnderCursor"=dword:00000000
: : "PollForeground"=dword:00000001
: : "PollFullScreen"=dword:00000000
: : "OnlyPollConsole"=dword:00000001
: : "OnlyPollOnEvent"=dword:00000000
:
: : "ConnectPriority"=dword:00000002
: I set this to "1" for a test earlier and was able to do 2 simultaneous
connects
:
: : *******************
: : REGEDIT4
: :
: : [HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default]
: : "SocketConnect"=dword:00000001
: : "AutoPortSelect"=dword:00000000
: Didn't have this here
:
: : "PortNumber"=dword:0000170c
: Again, didn't have this
:
: : "InputsEnabled"=dword:00000001
: : "LocalInputsDisabled"=dword:00000000
:
: : "IdleTimeout"=dword:00000000
: Didn't have this here either
:
: : "QuerySetting"=dword:00000002
: : "QueryTimeout"=dword:0000000a
: : "PollUnderCursor"=dword:00000000
: : "PollForeground"=dword:00000001
: : "PollFullScreen"=dword:00000000
: : "OnlyPollConsole"=dword:00000001
: : "OnlyPollOnEvent"=dword:00000000
:
: : "ConnectPriority"=dword:00000002
: Again, had a test setting of 1
: : Attachment(s):
: : HKCU.REG
: : HKLM.REG
: ---------------------------------------------------------------------
: To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: 'unsubscribe vnc-list' in the message BODY
: See also: http://www.uk.research.att.com/vnc/intouch.html
: ---------------------------------------------------------------------
: ---------------------------------------------------------------------
: To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
: 'unsubscribe vnc-list' in the message BODY
: See also: http://www.uk.research.att.com/vnc/intouch.html
: ---------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------