ConnectPriority - Registry info

Alex Angelopoulos alex "at" bittnet.com
Wed, 23 Jan 2002 18:17:46 +0000


COMPARISON OF REGISTRY VALUES

(SUMMARY NOTE: Tracy is having an issue with having a VNC server connection dumped when someone else connects to the same system.
She has, as can be seen, created the ConnectPriority DWORD with a value of "2", restarted the server, etc.)

Just a quick note - I am going to try checking this out on my system, but I did a quick check on the registry values.  The only
differences in our setups were the following values:

"AutoPortSelect" - mine was 1 as opposed to your "0" - but see next item
"PortNumber" - you had this which I didn't, but yours is set to 0x170c(5900), the default
"IdleTimeout" - Yours is "0"; I didn't have this setting
"ConnectPriority" - I had this set to "1"from checking your problem last week, and I *did* connect successfully from 2 locations
simultaneously.





---- Original Message -----
From: "Tracy Millar" <tmillar "at" idrc.ca>
To: <vnc-list "at" uk.research.att.com>
Sent: Wednesday/2002 January 23 12:38
Subject: Re: ConnectPriority - Registry info


: As requested, here are the registry files as per below...
:
: *********
: REGEDIT4
:
: [HKEY_CURRENT_USER\Software\ORL\WinVNC3]
: "SocketConnect"=dword:00000001

: "AutoPortSelect"=dword:00000000
Mine is 1; obviously you have a custom port setting

: "PortNumber"=dword:0000170c
Which is here...and is set to 5900 manually

: "InputsEnabled"=dword:00000001
: "LocalInputsDisabled"=dword:00000000

: "IdleTimeout"=dword:00000000
I don't even have this

: "QuerySetting"=dword:00000002
: "QueryTimeout"=dword:0000000a
: "PollUnderCursor"=dword:00000000
: "PollForeground"=dword:00000001
: "PollFullScreen"=dword:00000000
: "OnlyPollConsole"=dword:00000001
: "OnlyPollOnEvent"=dword:00000000

: "ConnectPriority"=dword:00000002
I set this to "1" for a test earlier and was able to do 2 simultaneous connects

: *******************
: REGEDIT4
:
: [HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default]
: "SocketConnect"=dword:00000001
: "AutoPortSelect"=dword:00000000
Didn't have this here

: "PortNumber"=dword:0000170c
Again, didn't have this

: "InputsEnabled"=dword:00000001
: "LocalInputsDisabled"=dword:00000000

: "IdleTimeout"=dword:00000000
Didn't have this here either

: "QuerySetting"=dword:00000002
: "QueryTimeout"=dword:0000000a
: "PollUnderCursor"=dword:00000000
: "PollForeground"=dword:00000001
: "PollFullScreen"=dword:00000000
: "OnlyPollConsole"=dword:00000001
: "OnlyPollOnEvent"=dword:00000000

: "ConnectPriority"=dword:00000002
Again, had a test setting of 1
: Attachment(s):
: HKCU.REG
: HKLM.REG
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------