twm process dies

martha.bohls@ni.com martha.bohls "at" ni.com
Tue, 22 Jan 2002 21:40:36 +0000


We've installed vncserver on Solaris 2.6.  We start the server and
everything works until the session that started the vncserver logs out.
The following message appears in the log and you can no longer connect to
the vncserver.
X connection to unix:13.0 broken (explicit kill or server shutdown).

Using ps shows that the Xvnc process is still running, but the twm and
xterm processes started in the xstartup script have died.
#!/bin/sh
xrdb /usr/dt/config/C/Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

We've tried using nohup to start vncserver
nohup vncserver :13 -pn -localhost &

Adding nohup to the xstartup script
nohup xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
nohup twm &

Adding nohup to the vncserver script
system("nohup $vncUserDir/xstartup >> " . &quotedString($desktopLog) . " 2>
&1 &");

Same result in all cases.  Is there a trick to keeping vnc working after
you log out of the startup session on the server?

Thanks for any help.

Martha Bohls
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------