Solaris 8 inetd

Roger Hale roger.hale "at" btconnect.com
Thu, 17 Jan 2002 12:47:38 +0000


I'm trying to get Xvnc -inetd working on a SPARC Solaris 8 system.

The behaviour I'm seeing is that a window does open when I connect from
a vncviewer, but dies again almost  immediately before the login screen
appears.  The log file indicates that Xvnc started, but doesn't indicate
an error (other than a message about ignoring type 3 encoding, which I
believe is harmless).

I have followed the instructions in the relevant web page (additions to
/etc/services, /etc/inetd.conf, etc.) and have setgid root Xvnc, as
described in this mailing list.  I've also tried various other proposed
solutions I found on the mailing list, but the problem persists. 

I have set up the server successfully on a Solaris 7 X86 system in (I
think) exactly the same way and that works fine.  I am at a loss to know
what the difference is (though the Solaris 7 system is running XFree86).
Any suggestions on where to look?

For the record, here are the settings:

/etc/services: added line

vnc-1024x768    5920/tcp                        # VNC server

/etc/inetd.conf: added line

vnc-1024x768    stream  tcp     nowait  nobody  /usr/local/etc/Xvncinetd
Xvncinetd

/usr/local/etc/Xvncinetd:

#!/bin/sh
exec /usr/local/bin/Xvnc -inetd -once -nevershared -query localhost
-geometry 1024x768 -depth 16

(I tried adding the fontserver option, which I don't have on the Solaris
7 system, but it made no difference).

Thanks,

Roger
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------