VNC Server setup on Linux

Joel Sherrill joel.sherrill "at" OARcorp.com
Tue, 15 Jan 2002 18:48:19 +0000


David Colliver wrote:
> 
> After all those people that looked, no-one spotted the deliberate mistake.
> (blush, for not proof reading it properly). I had two number 3s.
> 
> Anyway, back to this problem. I don't know enough about it, but my best
> guess would be
> 
> edit Xaccess and uncomment the line '*        #any host can get a login
> window'
>           a) RedHat 6.2, 7.1, 7.2 -' /etc/X11/xdm/Xaccess'
> 
> (was number 3, second one, now number 4)
> Ensure the line begins with the *
> 
> This is what I believe will give you the login window.

This file appears to be correct.

I am curious how I specify the host/port combination on the client
side.  I an using The TightVNC client and RPMs.  The grey screens
were with something like this:

192.168.1.21:5950

If I leave the port off or connect to 177, it fails.  Hmmm
I can't even connect to port 177.  Is that a problem?  Should 
port 177 be enabled?


> Hope this helps.
> Dave.
> ~~
> All I ask is a chance to prove that money can't make me happy.
> 
> Collectible dolls from http://www.collectorsdolls.com
> Web design? Web hosting? http://www.revilloc.com is the answer.
> Tips, tricks and articles for programmers of all languages on
> http://www.sourcecodecorner.com
> Planning a wedding? http://www.bmcweddings.com
> Advertise your car for free on http://www.drivingseat.com
> 
> ----- Original Message -----
> From: "Joel Sherrill" <joel.sherrill "at" OARcorp.com>
> To: <vnc-list "at" uk.research.att.com>
> Sent: Tuesday, January 15, 2002 6:06 PM
> Subject: Re: VNC Server setup on Linux
> 
> > Dumas Patrice wrote:
> > >
> > > Hi,
> > >
> > > I tried to do what the instructions are about in the past, but never
> > > succeded... I hope I will, now. Well, I tested, it works well !
> >
> > Thanks all.  This certainly seems to be closer for me but I must
> > still be missing something.  Perhaps something broken from my previous
> > attempts at this.  :(
> >
> > I am on RedHat 7.1
> >
> > I now have gotten far enough to get a grey screen on each of the
> > ports I have tried but no login screen.  I am getting a message
> > like this in /var/log/messages each time I get a grey screen
> > so I must be close. :)
> >
> > <date> <host> gdm[PID]: Failed to start X server several times in
> > a short time period: disabling display:0
> >
> > Any ideas on something I might have missed.?
> >
> > Thanks.
> >
> > --joel
> >
> 
> <snip>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> To download your own free RevilloC mailserver, visit http://www.revilloc.com/mailserver
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ---------------------------------------------------------------------
> To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
> 'unsubscribe vnc-list' in the message BODY
> See also: http://www.uk.research.att.com/vnc/intouch.html
> ---------------------------------------------------------------------

-- 
Joel Sherrill, Ph.D.             Director of Research & Development
joel "at" OARcorp.com                 On-Line Applications Research
Ask me about RTEMS: a free RTOS  Huntsville AL 35805
   Support Available             (256) 722-9985
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------