VNC on RH Linux stops local programs

Ceri Hankey ccah "at" thegreen.co.uk
Fri, 11 Jan 2002 22:04:27 +0000


I saw this on-going converstaion and thought that I would join in...

As an "ex-newbie" and now merely an "ignorant Linux hacker", I would
suggest, David, that you try to set up TWO Linux systems, One that you can
trust and love, and another that you can experiment and play with - IF you
have the disk space that is! It is a real luxury to have a WORKING Linux
system (I have Mandrake 8.0) and an experimental (nearly working) system
(Mandraake 8.1) on a totally different disk.

NB. if you log in as a user, then SU then run ANY X program, many of your
user oriented X files (in /home/user) will be changed to owner root:root. It
is dangerous to run X when in su mode.

If you are trying to run VNC as somebody else other than your normal
username, create a normal user account (eg vnc) and run vnc from there. You
can then get Linux to start vnc (under user vnc) via the file
/etc/rc.d/rc.local)

I have put the following lines at the end of my rc.local and it works
fine...
# turn vncserver on
su -l vnc -c "vncserver -cc 3 :1 -alwaysshared"
But BE SURE that you have run vnc from the vnc account first to kick the
password off.

Good luck

Ceri Hankey



----- Original Message -----
From: "David Colliver" <david.colliver "at" revilloc.com>
To: <vnc-list "at" uk.research.att.com>
Sent: Wednesday, January 09, 2002 11:01 PM
Subject: Re: VNC on RH Linux stops local programs


> ----- Original Message -----
> From: "Greg Breland" <gregory "at" netdoor.com>
> To: <vnc-list "at" uk.research.att.com>
> Sent: Wednesday, January 09, 2002 9:28 PM
> Subject: Re: VNC on RH Linux stops local programs
>
>
> > Well, since you are a self aknowledged "newbie", I will take say this
> > first. DON'T run as root.  Really, I promise it is not that hard to run
> > as another user and just use the "su" command when you need to install
> > or configure something.
>
>
> I know that much. I am in as root as I am trying to play with other stuff,
> like mySQL.
>
> If I login as me (not root), then su, then start vncserver with the KDE,
> will I still get the same problem? or will the vnc session be root, which
> shouldn't affect me.
>
>
> >
> > Ok, now that that is out of the way.  Edit the "xstartup" file in the
> > "~/.vnc/" directory.  Sounds like you already have a line like "startkde
> > &".  Comment this line out by putting a "#" in front of it.  Now below
> > the startkde line, add a new line with "exec gnome-session & ".  Kill
> > you existing vncserver with "vncserver -kill :1" assuming the existing
> > server is running on port 5901.  Start up a new server and you should be
> > running gnome.
>
> OK, Kill didn't give me back my control. :-( Going for a reboot.
>
> I will try that for gnome. (I can't get gnome working on my Linux box
> though. Hopefully it should work through VNC).
> ....
> Just tried that. Didn't work. :-(
> Probably a corrupt gnome. I just got what looks like TWM. At least it
didn't
> take my control away.
>
> Any ideas how I can make it so that VNC will autostart with linux, so that
> when I connect, I get the login box rather than the current user? This
> should get me around the problem I am having.
>
> Also, how can I make my remote screen bigger? My linux machine display is
> 1280, though what is coming through is about 1024.
>
> >
> > I highly recommend moving to RH 7.2 if possible as this will not only
> > fix your KDE problem per another post on this problem, but VNC is
> > installed by default. 6 months is a long time in the Linux world and 6.2
> > was about 18 months ago. RH 7.2 is amazing.
> >
>
>
> Let me get my head around 6.2 first. Once I understand more of the way
linux
> works, then I will start to really customise it.
>
> Thanks for your help so far.
>
> Regards
> Dave.
>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> To download your own free RevilloC mailserver, visit
http://www.revilloc.com/mailserver
>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ---------------------------------------------------------------------
> To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
> 'unsubscribe vnc-list' in the message BODY
> See also: http://www.uk.research.att.com/vnc/intouch.html
> ---------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, mail majordomo "at" uk.research.att.com with the line:
'unsubscribe vnc-list' in the message BODY
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------