Garbled IBM server Display

DERSHOWITZ, ADAM (JSC-DF) (USA) adam.dershowitz1 "at"
Wed, 26 Sep 2001 17:01:14 +0000

First off, thanks to Didier, I am now able to build and run the server.

But then when I try to connect to it from a Windows client the screen is
garbled.  I can open an xterm but all the characters are wrong (but the
keyboard functions correctly).  If I left click on the background the menu
that pops up is readable, but "blurry".  If I drag over the menu then things
become more clear.  So something is clearly very wrong.  

I have searched through the archives and have found that some others had a
very similar problem, but I could not find the solution in the archives.


ps I tried the build with each of the suggestions that Didier made, with the
same results described above.

-----Original Message-----
From: didier [mailto:dgautheron "at"]
Sent: Thursday, September 20, 2001 11:03 PM
To: vnc-list "at"
Subject: Re: Build Problems

> I am trying to build Xvnc on an IBM ZX7 that is running SuSSE Linux.  I
> able to build the client just fine by just doing xmkmf then make World.
> However when I then tried to build Xvnc by doing "cd Xvnc", followed by
> "make World" I got some compile errors that I was not sure what to make
> If anyone has any suggestions I would greatly appreciate.  The full
> info with the errors is listed below.
> I have not chagned anything in config/cs and would be happy to try any
> change that might help.
> Thanks,
> --Adam
> l003016:~/vnc/vnc_unixsrc/Xvnc # make World
> Building Release 6.3 of the X Window System.
> I hope you checked the configuration parameters in ./config/cf
> to see if you need to pass BOOTSTRAPCFLAGS.
> Thu Sep 20 11:05:09 EDT 2001
> imake.c: In function `get_ld_version':
> imake.c:961: warning: comparison is always true due to limited range of
May be a signed char - unsigned char pb, try
BOOTSTRAPCFLAGS=-fsigned-char, but you're in trouble anyway because.

> make[2]: Entering directory `/root/vnc/vnc_unixsrc/Xvnc/config/imake'
> gcc -O -ansi -pedantic  -I../../include -I../../exports/include/X11
> -I../../exports/include  -Dlinux LinuxMachineDefines
Pb here should be -Dsomething, xfree86 doesn't know about your arch. Try
with something like this (from XFree86 4) in config/cf/ just
before  BEGIN ORL VNC modification   
# define LinuxMachineDefines    -D__s390__
# define ServerOSDefines        XFree86ServerOSDefines -DDDXTIME
# define ServerExtraDefines     -DGCCUSESGAS XFree86ServerDefines
#define LinuxMachineDefines     -D__s390x__
#define ServerOSDefines         XFree86ServerOSDefines -DDDXTIME
#define ServerExtraDefines      -DGCCUSESGAS XFree86ServerDefines

> -DCPP_PROGRAM="\"/lib/cpp\""   -c -o imake.o imake.c
> gcc: cannot specify -o with -c or -S and multiple compilations
> make[2]: *** [imake.o] Error 1
> make[2]: Leaving directory `/root/vnc/vnc_unixsrc/Xvnc/config/imake'
> make[1]: *** [imake.bootstrap] Error 2
> make[1]: Leaving directory `/root/vnc/vnc_unixsrc/Xvnc'
> make: *** [World] Error 2
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at"
See also:
To unsubscribe, mail majordomo "at" with the line:
'unsubscribe vnc-list' in the message BODY
See also: