Win2K, VNC, ZoneAlarm

Carlos Alfaro carlosalfaro "at" yahoo.com
Wed, 12 Sep 2001 16:07:36 +0000


I am the one who had problems with win98 and Zone
Alarm and got no response so far.

Hope I can help.  You can edit Zone Alarm to allow the
ports you need to have open for Zone Alarm to work. 
Then the order in which the service start won't
matter.  I had a similar problem but fixed it by
allowing the VNC server to access the local network (
that is another question - do u want VNC to access the
net or just a local network) because Zone Alarm can
sometimes allow the first time for a service to run,
but it will not after is engaged its "lock" when the
screen saver kicks in.

Hope that helps and it doesnt confuse u more

Carlos
--- Andy Woo <Andy.Woo "at" ClubZ.org> wrote:
> Hi,
> 
> I searched through the archives and saw that someone
> was having reboot problems with Win2K and VNC. I
> also
> noticed someone indicating that they were having
> problems when VNC and ZoneAlarm were combined.
> 
> I have all three as part of my configuration,
> although
> I don't have the 'reboot' problem (I have a
> different 
> one, since I blew away my machine, I replaced Win98
> with Win2K, and I got a later version of VNC and
> ZoneAlarm... now when I 'restart'... the machines
> shuts down... goes to the dark screen... but, never
> re-starts back up. Similarly.... before I could
> 'shut down',
> and the machine would power itself down. Now I just
> get the 'it is safe to turn off your machine', and 
> I have to physically turn the machine off).
> 
> I am running VNC as a service (so that if I 
> re-start, VNC is running and I can log in remotely.
> Or even
> if a user has logged off.... VNC is still running,
> so I can
> log back in). 
> 
> So what happens is... since VNC is running
> as a service, it starts before ZoneAlarm (which is
> an app, that
> runs after a user logs into Win2K).  This causes 
> remote access via VNC to NOT WORK. It essentially
> times-out
> or can't get in.  I had a friend try to log in... he
> kept
> getting non-recognition.... and I could see his
> attempts
> at port 5800 within my firewall software.
> 
> However, if I log in at the computer... 
> (hence, VNC was running as a service, then after log
> in, 
> ZoneAlarm is running) If I stop the service, 
> and re-start the VNC as an app, VNC remote works
> fine.
> 
> It seems like the sequence has to be ZoneAlarm
> (first), then VNC (second).
> I'm guessing that app versus service is not
> important... ie. if I re-started
> the VNC service instead of running the app., as long
> as it's started AFTER
> ZoneAlarm, I'd still be ok.
> 
> Is anyone familiar with this ? Have a solution ?
> I want to try to retain it as a service, so that I
> don't have to be logged
> in at the computer, to get in remotely.
> 
> I even thought of giving up on that, and creating a
> batch file, that
> could be run... so that ZoneAlarm starts first, then
> VNC... giving up
> on the
> no-user-logged-in-but-can-still-log-in-remotely
> scenario.
> 
> I created a batch file with two lines.. the first
> line running ZoneAlarm, 
> the second running VNC... but when I run the batch
> file... after running
> ZoneAlarm,... it never returns to continue to run
> VNC. I'm probably missing
> something very simple and basic.
> 
> The file is pretty straigthforward :
> 
> "c:\Program Files\ZoneAlarm\zonealarm.exe" -nopopup
> "c:\Program Files\ORL\VNC\WinVNC.exe" -run
> 
> Can someone please help me out?
> 
> Thanks in advance,
> 
> 
> Andy
>
---------------------------------------------------------------------
> To unsubscribe, send a message with the line:
> unsubscribe vnc-list
> to majordomo "at" uk.research.att.com
> See also:
> http://www.uk.research.att.com/vnc/intouch.html
>
---------------------------------------------------------------------


__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------