font problem? - please help

Russell Goyder rg200 "at" hermes.cam.ac.uk
Tue, 11 Sep 2001 23:24:40 +0000


I am trying to run vncserver (version 3.3.3-10) on Debian Potato,
eventually to connect to a windows machine and vice-versa on my home
network. I have tried quite a few things but to no avail, so here goes:

I type "vncserver" as root.

It gives:

New 'X' desktop is russmachine:1

Starting applications specified in /etc/X11/Xsession
Log file is /root/.vnc/russmachine:1.log

which looks quite good.

Then I try to connect to it with "xvncviewer russmachine:1" and I get

/usr/X11R6/bin/xvncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server

In the file /root/.vnc/russmachine:1.log there is

11/09/01 23:01:26 Xvnc version 3.3.3
11/09/01 23:01:26 Copyright (C) 1999 AT&T Laboratories Cambridge.
11/09/01 23:01:26 All Rights Reserved.
11/09/01 23:01:26 See http://www.uk.research.att.com/vnc for information
on VNC
11/09/01 23:01:26 Desktop name 'X' (russmachine:1)
11/09/01 23:01:26 Protocol version supported 3.3
11/09/01 23:01:26 Listening for VNC connections on TCP port 5901
11/09/01 23:01:26 Listening for HTTP connections on TCP port 5801
11/09/01 23:01:26   URL http://russmachine:5801
failed to set default font path ''
Fatal server error:
could not open default font 'fixed'
Couldn't connect to russmachine:1

So maybe my problem is with fonts? The same problem occurs when I try it
as a normal user (running both the server and client) with the same error.
I searched the mailing list archives for fonts and the like, and found one
person who appeared to have the same problem, but he fixed his by running
as root, which is why I chose to in the above example.

vnc looks so cool, it's fustrating to not get it working! Thanks for any
help,

Russell
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------