Disabling client computer's modifier keys

a.umpleby@ic.ac.uk a.umpleby "at" ic.ac.uk
Wed, 27 Jun 2001 23:24:16 +0000


>I installed VNCThing and tried it. Same problem.

Yes, VNCThing does not have such an extensive ability to map keypresses
as the original AT&T version. 'twould be nice...

>For example, if I'm in the Finder and issue Command-N (new folder),                   
>VNCThing's New Session window pops up

If you're using ChromiVNC Server on the server Mac then you can get a 
command key emulated at the server end by using ctrl and option.
i.e. use ctrl-opt-N to get a new folder in the Finder.

> "Release Modifiers", doesn't seem to do anything.

Yes it does - but it only does if something goes wrong to start with. 
Basically, there are times when the server (for whatever reason) thinks
that a modifier key is 'stuck' down - and any keypresses are sent as if
the character has been produced with that modifier (it can also happen
with mouse clicks). "Release modifiers" will attempt to 'unstick' this
situation - presumably, by explicitly sending the server a 'release-
key-command' after it had really happened at the client end.
(Is this roughly correct, Dair?)

> Furthermore, it takes 4 quick mouse clicks (not two) to open a folder

This is a Finder-specific problem and comes about because of the fact
that the Finder 'blocks' everything immediately after an icon is first  
clicked on for an amount of time that I think corresponds to the
double-click time set in the mouse control panel.

This can be demonstrated quite easily by setting up your menubar clock
(there's no VNC involved here...) to display seconds and to flash the
separators. If you click on an icon just before the second is about to
change, you will notice that the second change gets delayed for a short
time. (If you have another program that shows continuous updates quite
rapidly, you can also see it 'pausing' when you click an icon - and if 
you change the double-click time, you will see the pause length changes
with it...)

I have tried numerous ways to get around this, but the only way I've  
got it work so far is by using Mac OS 8.1 (not 8.0 nor 8.5!) with the
control strip visible (i.e. hiding the control strip brings back the
problem). Curiously, this configuration also allows dragging to work
correctly (with the standard vncPatches).

ation also allows dragging to work
correctly (with the standard vncPatches).

If any Mac guru out there can make something out of this totally 
bizarre situation, I would be very willing to hear it!!

Anyway, enough...

Bye!

=====================================================================
 Adrian Umpleby   adrian "at" ic.ac.uk  http://wrench.et.ic.ac.uk/adrian/
=====================================================================
  vncPatches68k:-   http://wrench.et.ic.ac.uk/adrian/software/vnc/
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------