Xvnc -inetd

Edric Bulalacao egb "at" tonesoft.com
Mon, 27 Aug 2001 16:02:44 +0000


Gary,
	Your server_args has too many args...remove Xvnc in server_args.  That
should take care of your problem.


============================================================================
==
Hi all,

before trying to install KDE2.2 hosed my system I used to have Xvnc set up
as
a service through xinetd.  Now, when I try to set it up again it doesn't
work.  If I try to connect using a Linux viewer I get not a valid server.

If I connect using a Win32 viewer, I get invalid protocol.


If I run Xvnc from the comand prompt as below, it works fine.

 Xvnc :1 -query gary -geometry 1024x768 -depth 24 -once &

My services file has:

vnc-640x480x8   5950/tcp                        # VNC
vnc-800x600x8   5951/tcp                        # VNC
vnc-800x600x16  5952/tcp                        # VNC
vnc-1024x768x16 5953/tcp                        # VNC

and  /etc/xinetd.d/vnc-1024x768x16  is:


service vnc-1024x768x16
{
        socket_type             = stream
        protocol                = tcp
        wait                    = no
        user                    = nobody
        server                  = /usr/bin/Xvnc
        server_args             = Xvnc -inetd -query gary -once -geometry
1024x768 -depth 16
        disable                 = no
}
[root "at" gary /root]#
- --
Gary Stainburn
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------