VNC remote install and connection closed

Carius, Frank frank.carius "at" netatwork.de
Wed, 22 Aug 2001 15:08:14 +0000


Hello,

VNC running very well. Windows NT4  W2K  always as service.
Installation using "WINVNC -install" is working.
I normally insall it "remotely". It works with 3.3.2 but no longer with
3.3.3r9

What i to: i create a batch top start as administrator:
WINVNC ist installed locally as service with a password set
Resource Kit Tools SC.EXE and REG.EXE are used


Than i start as admin: "INSTALLVNC  servername"

Here the content of INSTALLVNC.CMD  (unneeded comments and error
handling deleted)

@echo off
echo Remote Installation VNC
echo -------------------------------------
	
echo INSTVNC %1 Check exitence of VNC Service Kennwort
REG QUERY HKLM\Software\ORL\WinVNC3\Default\Password  |find "REG_BINARY"
if errorlevel 1 goto error3

rem ------------ Copy files ---------
xcopy winvnc.exe \\%1\admin$\system32\
xcopy vnchooks.dll \\%1\admin$\system32\
xcopy omnithread_rt.dll \\%1\admin$\system32\

Rem ------------ install service and setup to interactive
sc \\%1 create winvnc binpath= "%%Systemroot%%\system32\winvnc.exe
-service" start= demand DisplayName= WinVNC type= own
echo Y | REG update
HKLM\System\CurrentControlSet\Services\winvnc\Type=272 \\%1

echo INSTVNC %1 copy registry for password
echo Y | REG COPY HKLM\Software\ORL\WinVNC3 HKLM\Software\ORL\WinVNC3
\\%1

rem ------------ Start Service ---------
sc \\%1 start winvnc > nul:
rem ------------ Start remove control ---------
vncviewer %1



I tried many things. I captured the process of "WINVNC -INSTALL" using
WinInstall LE and SMS Installert and SYSDIFF.  I compares registy values
etc.

It is not necessary to have the helper app running.
Ist not necessary to have any other registry keys.
I tired it using "WINVNC -install" for installation and removed all keys
except the password key. But i get always a "Connection closed"

I used a wrong password and got a "authorisation failure", so it looks
fine. I also tried to unterstand the source but i'm not a real C++
programmer (sorry)

I know i can schedule a "WINVNC -instal" using AT command or WMI buw AT
needs "time" and WMI is not always availible. So any hint, why winvnc
does not allow me to control the station if i install it with "SC.EXE" ?


--
Frank Carius
--------------------------------------------
http://www.NetatWork.de , Riemeke Str 160, 33106 Paderborn
Tel +495251 304 600, Fax +495251 304 650
no advertising or spam mails PLEASE!!
Franks Exchange FAQ auf http://www.msexchangefaq.de
Supportanfragen nur an support "at" netatwork.de
--
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------