Solaris 7 compilation issues

Quek Hong Cheang quekhc "at"
Thu, 09 Aug 2001 02:43:29 +0000

Hi Frank

Just like I have emailed Const, I think the problem does not lie with the source code (I think I should be having the lastest one, just downloaded them less than a month ago), but rather, it lies with my inexperience in compiling codes.  I am still a novice in all these kind of things, so I guess there are really a lot to learn.  If it is not too troublesome, please tar and gz the executable files and send them to :

quekhp "at"

Thank you so much.  If you are interested in the problems that I have faced, here it goes :

I have already downloaded the lastest gcc from sunfreeware and when I started compiling it with xmkmf, it complained of missing "#endif" in some file and the whole thing terminated. I do not know how to debug it and so felt very frustrated. :|

By the way, I tried out TridiaVnc yesterday and I was so disappointed because it was actually slower than the normal vnc that I got from AT&T.  Not sure if I am the one who is using it incorrectly but when I used the "tight" option, the screen actually started refreshing portion by portion horizontally. The hextile option still works fine, just can't figure out why the tight option is not working. By the way, what does the lazytight option actually do???  I have tried to use that but does not really made a difference.  

I am using 100BaseT LAN and connecting between Solaris 7 and Win98.  My aim is to make vnc work as fast as what a normal X server program such as XWin32 or Xmanager  can achieve.  Currently whenever I use vnc, it is slow in the sense that there is an irritating time lack between clicking a menu(or moving a window) and actually seeing the click being performed.  Also, the cursor is constantly trailing behind a little dot.  Have already tried setting some options such as deferupdate, but does not help very much.  Did not face such problem using those X server programs.

Anyone else faces the same problem?

On Wed, 08 August 2001, Frank Evan Perdicaro wrote:

> > Subject: Re: Upgrading VNC (was TightVNC vs regular VNC)
> > 
> > Speaking of upgrading, I have been trying to compile tightvnc without much success.  Is there anyone who has sucessfully compiled it on the solaris platform?  I am using Solaris 7. If anyone can sent me the compiled files, I would be very grateful.  Thanks.
> > PS : Any version of solaris is worth a try.  
> > 
> As Const has generated new version of TightVNC, I have verified his
> work on Solaris 7.
> There have been bumps in the road.  Early on, say a 10 months ago,
> Const has some bogus instructions, as far as Solaris goes.  He thought
> all was well, but there were problems with patch.  He and I worked
> through the issues, using script and truss and make to find the exact
> parameters.  Eventually he agreed it was not possible to compile Tight
> on Solaris 7 (as it existed) and he eventually changed the make
> method.  So if you have OLD Tight code, it WILL NOT COMPILE under
> Solaris 7.  (More properly it will not patch, so the Makefile
> eventually fails to produce a finished product.  The end result is the
> same -- no useful product.)
> I have the email/logs where Const and I tracked down the problem.  If
> doubters really want to see them, and Const agrees, I could provide
> them.
> All that is history.  If you get a recent gcc from
> and a recent TightVNC from (not Tridia) I can assure you
> it works.  Const reacted to my observations and fixed the
> distribution.  The compile works, and the resulting products works
> quite well.  My wife uses it every day.
> If you can provide an FTP site, I might be able to send you the
> files.
> ---------------------------------------------------------------------
> To unsubscribe, send a message with the line: unsubscribe vnc-list
> to majordomo "at"
> See also:
> ---------------------------------------------------------------------

Find the best deals on the web at AltaVista Shopping!
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at"
See also: