Macros in Win16 app freeze w/slow connection

James ''Wez'' Weatherall jnw22 "at" cam.ac.uk
Tue, 21 Nov 2000 17:00:53 +0000


I have no idea why the apps are playing up.  I suspect it's application
specific, not Win16 or Win32 specific, but it's very hard to tell.  It could
just be a Win95 problem.

Cheers,

James "Wez" Weatherall
--
          "The path to enlightenment is /usr/bin/enlightenment"
Laboratory for Communications Engineering, Cambridge - Tel : 766513
AT&T Labs Cambridge, UK                              - Tel : 343000

----- Original Message -----
From: "Eugene Flitman" <flitman "at" d902.iki.rssi.ru>
To: <vnc-list "at" uk.research.att.com>
Sent: Monday, November 20, 2000 2:02 PM
Subject: Re: Macros in Win16 app freeze w/slow connection


> There were no application entries in registry for win16 applications. I
> added them and added "use_Deferral" parameter set to zero. Is that
> what you meant?
>
> Also, while I'll test the results, I'd like to understand (since I
actually
> have 4 machines in similar configuration) - is the problem specifical to
> Win16 applications, or slow modem connection - should I also set this
> option for Win32 apps on these machines?
>
> Thanks.
> Eugene.
>
> > Find the name of the Win16 executable and then look in the VNCHooks
> > settings in the current user's registry.  One of the keys under the
> > problem application's entry there will be "use_DeferredUpdate" - set
> > this to zero and your problem should go away.
> >
> > To find the name of the app, press C-A-D and note the list of
> > processes, then cancel, run the app, and C-A-D again!
> >
> > Cheers,
> >
> > James "Wez" Weatherall
> > --
> >           "The path to enlightenment is /usr/bin/enlightenment"
> > Laboratory for Communications Engineering, Cambridge - Tel : 766513
> > AT&T Labs Cambridge, UK                              - Tel : 343000
> >
> > ----- Original Message -----
> > From: "Eugene Flitman" <flitman "at" d902.iki.rssi.ru>
> > To: <vnc-list "at" uk.research.att.com>
> > Sent: Monday, November 20, 2000 11:45 AM
> > Subject: Macros in Win16 app freeze w/slow connection
> >
> >
> > > I have Win95 with WinVNC 3.3.3 R7. I have series of Win16
> > > applications running automatically from a Win32 scheduling
> > > application. Win16 apps perform automatic image processing (with
> > > massive and fast window updates) by running macros (implemented thru
> > > a message queue). When I connect to WinVNC over a 28.8 modem, the
> > > macros stop running after several macro operations, just get paused
> > > indefinitely without any reason - the program still responds but
> > > macros don't run, though the program reports to be in "macro
> > > running" mode. Over a 10Mbit LAN everything works fine.
> > >
> > > Any ideas for the reason and how to fix it? Should I disable WinVNC
> > > deferral and for which apps (all Win16, or Win32 scheduler)? May
> > > upgrade to Win98 help?
> > >
> > >
> > >
>
> Eugene Flitman,
> Leading software engineer,
> SMIS Lab, Space Research Institute (Moscow, Russia).
> ------------------------
> flitman "at" d902.iki.rssi.ru
> +7(095)333-5313(w) +7(095)420-6948(h) +7(901)732-4408(mob)
> http://smis.iki.rssi.ru, http://meteo.infospace.ru
> ---------------------------------------------------------------------
> To unsubscribe, send a message with the line: unsubscribe vnc-list
> to majordomo "at" uk.research.att.com
> See also: http://www.uk.research.att.com/vnc/intouch.html
> ---------------------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------