VNC, Opus, and my nightmare

Jeff Boerio boerio "at" ichips.intel.com
Fri, 25 Aug 2000 17:00:19 +0000


In our environment here, we have our CAD tools layered within wrapper after
wrapper of environment settings.  This seems to be confusing xauth and Opus.
We don't use xauth in our regular environment, relying only on xhost to do
whatever the customer wants.  The VNC server is running on an AIX 4.1.4
machine, and is the same machine that I'm trying to run Opus.

The short problem is that Opus won't come up.  It is displaying the
following error message when trying to run icde:

	Client is not authorized to connect to Server
	X Toolkit Error: Can't Open display

So that's not real helpful.  But, xauth does have entries for my display,
and I can bring up other X Windows apps from the commandline without problem.

I think that somewhere in all the wrappers, something is telling Opus to
use the display localhost:2 instead of the hostname (pdx484:2), and that's
what's killing things.  For some reason, I cannot "setenv DISPLAY
localhost:2" and have a window come up.  xauth doesn't like that.

% xauth list
pdx484.pdx.intel.com:2  MIT-MAGIC-COOKIE-1 7c224dd044dc46fa3e63aa42113a4d0b
pdx484/unix:2  MIT-MAGIC-COOKIE-1  7c224dd044dc46fa3e63aa42113a4d0b
localhost:2  MIT-MAGIC-COOKIE-1  7c224dd044dc46fa3e63aa42113a4d0b

% ps axugwww | grep Xvnc
boerio   28470  2.8  1.0 2316 3352 pts/10 A    08:22:28  0:26 Xvnc :2 -desktop X -httpd /usr/intel/pkgs/vnc/3.3.3r1/classes -auth /fs3/e/boerio/.Xauthority -geometry 1024x768 -depth 8 -rfbwait 120000 -rfbauth /fs3/e/boerio/.vnc/passwd -rfbport 5902 -fp /usr/lib/X11/fonts/,/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/,/usr/lib/X11/fonts/ibm850/ -co /usr/lib/X11/rgb 

% echo $DISPLAY
pdx484:2

% xterm

% echo $status
0

% setenv DISPLAY localhost:2
Xlib:  connection to "localhost:2.0" refused by server
Xlib:  Client is not authorized to connect to Server
Error: Can't open display: localhost:2

I've tried a plethora of things, including tracing the process, forcing
DISPLAY variables to get set at different points, but nothing seems to be
helping.

So my questions are this: 
* Any suggestions on how to work through this issue?  I have tried 
  issuing a -display option, but that doesn't seem to have any effect.
* Any ideas on why localhost:2 won't work as a valid display name?

I think answering either one of those questions will help solve my problem.

     - Jeff
---------------------------------------------------------------------
To unsubscribe, send a message with the line: unsubscribe vnc-list
to majordomo "at" uk.research.att.com
See also: http://www.uk.research.att.com/vnc/intouch.html
---------------------------------------------------------------------