vncserver script misbehaving

Marcus Brinkmann Marcus.Brinkmann "at" ruhr-uni-bochum.de
Thu, 29 Oct 1998 22:11:30 +0000


On Wed, Oct 28, 1998 at 10:43:48AM +0100, Georg Hager wrote:

Hello, 

> I'm using Debian Linux 1.3.1 (libc5). When starting the vncserver script
> (newest version just downloaded from orl) then nothing happens apart from
> perl obviously eating up more and more memory until it dies with an out of
> memory error (I have 64MB plus 64MB swap). I'm not familiar with perl, but
> it seems that it's the "eval 'require "sys/socket.ph"';' statement that
> gives the trouble. Am I using a version of perl that is too old? 

Are you using perl 5.005? It is known to have severe problems with certain
constructs.

The Debian vncserver script is different from the upstream script, btw. I
must know it, because I'm the Debian maintainer of VNC :)  [I sent it to the
developer address but didn't heard back].

If you are using perl 5.005, downgrade to the working Debian version, it
should help. If not, we need some more debugging information...

Marcus

-- 
"Rhubarb is no Egyptian god."        Debian GNU/Linux        finger brinkmd@ 
Marcus Brinkmann                   http://www.debian.org    master.debian.org
Marcus.Brinkmann "at" ruhr-uni-bochum.de                        for public  PGP Key
http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       PGP Key ID 36E7CD09

---------------------------------------------------------------------
The VNC mailing list     -   see http://www.orl.co.uk/vnc/intouch.html
---------------------------------------------------------------------