failed to bind listener, again

Tristan Richardson tjr "at" orl.co.uk
Fri, 16 Oct 1998 11:44:14 +0000


"Bob Nirenberg" <RNIRENBE "at" us.oracle.com> writes:

> Hi.  I know this issue is in the list archives, but I did not get what the
> solution is.  I run vncserver on a SunOS 5.5 machine, and everything seems
> okay.  Then when I attempt to start the viewer on a Windows NT 4.0 machine,
> I get:
> 
> _XSERVTransSocketCreateListener: failed to bind listener
> _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
> _XSERVTransMakeAllCOTSServerListeners: failed to create listener for local
>  
> Fatal server error:
> Failed to establish all listening sockets
> ...
> 
> There was a note about the /tmp/.X11-unix directory, which on my machine is
> in fact owned by root, and does not allow others to write to.  I do not have
> root access on the server, so perhaps one of the other suggested solutions
> would work, but I don't know exactly how to do them.
> 
> I tried modifying the perl script vncserver so that instead of creating
> .X11-unix in /tmp, it does so in ~/.vnc, which is obviously owned by me. 
> However, I got the same error messages.
> 
> Is there a way to get this to work without having root access?


Try giving Xvnc a "-pn" option - this tells it to continue even though it
couldn't listen on the unix domain socket.  Note that you'll always need to
explicitly use the hostname when specifying the DISPLAY to your X applications
(e.g. "hostname:1" rather than just ":1").

Cheers

Tristan

+-------------------------------------------------------------------------+
  Tristan Richardson, ORL, 24a Trumpington Street, Cambridge, CB2 1QA, UK
     tjr "at" orl.co.uk      Tel: +44 1223 343000      Fax: +44 1223 313542
+-------------------------------------------------------------------------+
  ORL - The Olivetti & Oracle Research Laboratory    http://www.orl.co.uk
+-------------------------------------------------------------------------+

---------------------------------------------------------------------
The VNC mailing list     -   see http://www.orl.co.uk/vnc/intouch.html
---------------------------------------------------------------------