AIX problems on v4.2.1

Michael Grabenstein mgrabens "at" sandbox.isinet.com
Thu, 15 Oct 1998 17:04:11 +0000


    Thanks to Charles Hines's patch for 4.2.1 I have a very stable
version of Vnc on one of my AIX boxes.

    Now here is the strange part. On some of my AIX 4.2.1 boxes I get
this error in the log file:
15/10/98 11:47:15 Xvnc version 3.3.XvncRelease
15/10/98 11:47:15 Copyright (C) 1997-8 Olivetti & Oracle Research
Laboratory
15/10/98 11:47:15 See http://www.orl.co.uk/vnc for information about
VNC
15/10/98 11:47:15 Desktop name 'X' (aixport:1)
15/10/98 11:47:15 Protocol version supported 3.3
15/10/98 11:47:15 Listening for VNC connections on TCP port 5901
15/10/98 11:47:15 Listening for HTTP connections on TCP port 5801
15/10/98 11:47:15   URL http://aixport:5801
xrdb: A remote host refused an attempted connect operation.
1356-605 xrdb: Can't open display 'aixport:1'
1356-265 xsetroot:  Unable to open display:  aixport:1.
Error: Can't open display: aixport:1
1356-200 xhost unable to open display "aixport:1"

    Note the lines starting with xrdb do not appear in the log file
until after I attempt to connect with vncviewer.

    The ony difference I have been able to see between the machine
that is working and the above host is that it has an X11 patch for
xdm on it:
X11.apps.xdm                            4.2.1.1             4.2.1.0

    Other than that they are both at the same os level (v4.2.1.0)

    I have tried building Vnc on both machines and running it. No
progress. I get the same error messages. And the compilation messages
look the same as well.

    Also interesting is that I get the same error message if I run
the AIX 4.2.1 binary on our AIX 4.3 box.

    Only thing is I have only tried IBM's C compiler... We do have
gcc installed on one of them.

    Any other ideas ??

Thanks,
    Mike


---------------------------------------------------------------------
The VNC mailing list     -   see http://www.orl.co.uk/vnc/intouch.html
---------------------------------------------------------------------