failed to bind listener, again

Bob Nirenberg RNIRENBE "at" us.oracle.com
Thu, 15 Oct 1998 16:40:34 +0000


Hi.  I know this issue is in the list archives, but I did not get what the
solution is.  I run vncserver on a SunOS 5.5 machine, and everything seems
okay.  Then when I attempt to start the viewer on a Windows NT 4.0 machine,
I get:

_XSERVTransSocketCreateListener: failed to bind listener
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for local
 
Fatal server error:
Failed to establish all listening sockets
xrdb: Connection refused
xrdb: Can't open display 'hostname:1'
xsetroot:  unable to open display 'hostname:1'
twm:  unable to open display "hostname:1"
Error: Can't open display: hostname:1

(Note I've changed the name of the server host).

There was a note about the /tmp/.X11-unix directory, which on my machine is
in fact owned by root, and does not allow others to write to.  I do not have
root access on the server, so perhaps one of the other suggested solutions
would work, but I don't know exactly how to do them.

I tried modifying the perl script vncserver so that instead of creating
.X11-unix in /tmp, it does so in ~/.vnc, which is obviously owned by me. 
However, I got the same error messages.

Is there a way to get this to work without having root access?

Thanks,

Bob N.
 
 
 
===================================================================
Robert Nirenberg, Ph.D.                      rnirenbe "at" us.oracle.com 
Applications Architect                         phone (914) 773-8489 
Oracle Process Manufacturing                     fax (914) 773-8001
Research and Technology    100 Summit Lake Drive, Valhalla NY 10595     
===================================================================
"The views  expressed herein may or may not truly be those of the
author but are even less likely to be those of Oracle Corporation.
Together with his employer, the author strongly urges  readers  not
to make marketing, stock purchase, or any other decisions based on
anything the author may say in this note or in any other forum at
any time." 
===================================================================







---------------------------------------------------------------------
The VNC mailing list     -   see http://www.orl.co.uk/vnc/intouch.html
---------------------------------------------------------------------