Irix 6.2 Build

matthew joseph valenta mvalenta "at" u.washington.edu
Tue, 13 Oct 1998 22:56:44 +0000


Hello,
I'm trying to build the VNC server on an Irix 6.2 System.  I applied the
appropriate patch from the Contributions area, but one of the two changes
failed, so edited the appropriate file by hand.  Then, I successfully
compiled vncpassword, vncviewer, etc.  Finally, I tried to build Xvnc
which failed and I'm unsure why.  

Any help and/or binaries would be appreciated.  Compiler output below.

Thanks,
Matt Valenta
mvalenta "at" u.washington.edu
mattv "at" ponty.rprc.washington.edu


Here is the patch error:
-------START-----------
ponty{mattv}153: patch <vnc-irix6.2.patch 
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- ./Xvnc/programs/Xserver/cfb/Imakefile       1998/09/08 14:13:47
1.1
|+++ ./Xvnc/programs/Xserver/cfb/Imakefile       1998/09/10 20:23:09
--------------------------
Patching file ./Xvnc/programs/Xserver/cfb/Imakefile using Plan A...
Hunk #1 failed at 193.
1 out of 1 hunks failed--saving rejects to
./Xvnc/programs/Xserver/cfb/Imakefile.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|
|--- ./Xvnc/config/cf/vnc.def    1998/09/09 18:46:41     1.1
|+++ ./Xvnc/config/cf/vnc.def    1998/09/10 20:21:20
--------------------------
Patching file ./Xvnc/config/cf/vnc.def using Plan A...
Hunk #1 succeeded at 132.
Hmm...  Ignoring the trailing garbage.
done
----------END------------

Then I compiled vncviewer, vncpassword, and they seemed to compile
correctly:
----------START----------
make[2]: Leaving directory `/usr/people/mattv/temp/vncviewer'
making all in ./vncpasswd...
make[2]: Entering directory `/usr/people/mattv/temp/vncpasswd'
/usr/bin/cc -O2 -xansi -32 -mips2  -Wf,-XNh2000  -I../include   -nostdinc
-I/usr/include -DSYSV -DSVR4  -DFUNCPROTO=7 -DNARROWPROTO     -c
vncpasswd.c -o vncpasswd.o
rm -f vncpasswd
/usr/bin/cc -o vncpasswd -O2 -xansi -32 -mips2  -Wf,-XNh2000
vncpasswd.o ../libvncauth/libvncauth.a -nostdlib -L/usr/lib/mips2
-L/usr/lib     
make[2]: Leaving directory `/usr/people/mattv/temp/vncpasswd'
make[1]: Leaving directory `/usr/people/mattv/temp'

Built libvncauth vncviewer vncpasswd.
To build Xvnc, do "cd Xvnc", followed by "make World"
----------END-----------

Finally, I tried to build Xvnc which died with this error:
----------START---------
ponty{mattv}96: cd Xvnc/
/usr/people/mattv/temp/Xvnc
ponty{mattv}97: make World

Building Release 6.3 of the X Window System.

I hope you checked the configuration parameters in ./config/cf
to see if you need to pass BOOTSTRAPCFLAGS.

Tue Oct 13 14:25:53 PDT 1998

cd ./config/imake && make  -f Makefile.ini BOOTSTRAPCFLAGS="" clean
make[1]: Entering directory `/usr/people/mattv/temp/Xvnc/config/imake'
rm -f ccimake imake.o imake
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a tags TAGS make.log
\#*
rm -f -r Makefile.proto Makefile Makefile.dep bootstrap
make[1]: Leaving directory `/usr/people/mattv/temp/Xvnc/config/imake'
make  Makefile.boot
make[1]: Entering directory `/usr/people/mattv/temp/Xvnc'
cd ./config/imake && make -w -f Makefile.ini BOOTSTRAPCFLAGS=""
make[2]: Entering directory `/usr/people/mattv/temp/Xvnc/config/imake'
making imake with BOOTSTRAPCFLAGS= in config/imake
cc -o ccimake  -O -I../../include -I../../imports/x11/include/X11
ccimake.c
cc -c  -O -I../../include -I../../imports/x11/include/X11 `./ccimake`
imake.c
cc -o imake  -O -I../../include -I../../imports/x11/include/X11 imake.o
make[2]: Leaving directory `/usr/people/mattv/temp/Xvnc/config/imake'
rm -f ./config/makedepend/Makefile.proto
./config/imake/imake -I./config/cf  -s ./config/makedepend/Makefile.proto
-f ./config/makedepend/Imakefile -DTOPDIR=../..
-DCURDIR=./config/makedepend
cd ./config/makedepend && rm -f -r Makefile Makefile.dep makedepend *.o
bootstrap
cd ./config/makedepend && make -f Makefile.proto bootstrap
make[2]: Entering directory
`/usr/people/mattv/temp/Xvnc/config/makedepend'
Makefile.proto:651: *** missing separator.  Stop.
make[2]: Leaving directory `/usr/people/mattv/temp/Xvnc/config/makedepend'
make[1]: *** [depend.bootstrap] Error 2
make[1]: Leaving directory `/usr/people/mattv/temp/Xvnc'
make: *** [World] Error 2
----------END----------


---------------------------------------------------------------------
The VNC mailing list     -   see http://www.orl.co.uk/vnc/intouch.html
---------------------------------------------------------------------