problems with vncviewer in linux 2.0.33

Jim Jowski jim "at" sm5323.mcclellan.af.mil
Wed, 18 Mar 1998 19:34:25 +0000


Tristan Richardson wrote:
> 
> > This is my second attempt at trying to get Windows VNC and
> > vncview under linux to play together.  The windows version
> > loads fine in Win95 and puts itself at the bottom right
> > corner of the screen like I think it should.  In linux,
> > the precompiled binaries are in /usr/local/bin and the java
> > classes are in /usr/local/vnc/classes and when I start up
> > 'vncviewer windows_machine:0' I get a grey window and a dot
> > cursor with nothing but a title.  When I tried to use the
> > broweser to look at 'windows_machine:5800', I get another
> > blank display.
> 
> Are you sure the linux machine can talk to the windows machine?  Try pinging
> it.  If that works try telnetting to the VNC port (5900) on the windows
> machine.  You should get something like:
> 
>   ~% telnet snoopy 5900
>   Trying 158.124.80.103...
>   Connected to snoopy.cam-orl.co.uk.
>   Escape character is '^]'.
>   RFB 003.003
>   ^]
> 
>   telnet> quit
>   Connection closed.
> 
> If all this works then there must be a more subtle problem, but I'd be
> surprised if that was the case.

The 'bummer' of the whole thing is that I got exactly the messages you
just referenced.  When I tried to do an http://snoopy:5900, all I got
was
the blank reply in the browser also.  So, I guess it's either the
Windows
version isn't passing the info back through the connection that it has
opened or the Linux version isn't accepting the data in both 'vncviewer'
and 'Netscape'.  I kinda doubt that it's the Linux side since 'Netscape'
works on other sites.  One thing that the Windows box won't do is see
the Linux box with the browser.  The Windows box will ping the Linux box
and vice-versa and ftp and telnet work.

I hope this helps shine more light on my problem,
Jim