vncserver error message: unknown encoding type 3

Brett M Hogden hogden "at" rge.com
Tue, 03 Mar 1998 21:03:00 +0000


-----BEGIN PGP SIGNED MESSAGE-----

I recently retrieved vnc-3.3.1_unixsrc and compiled those sources on a
box running SunOS 4.1.4 and X11R6.3.  Additionally, I retrieved
vnc-3.3.1_x86_win32.

The vncviewer running on the Sun seems to work just fine in
conjunction with a vncserver running in both Win'95 and NT.  However,
I've had problems getting things to work in the other, more preferred,
direction.

Using only the default settings for both the server and the viewer, I
get the following output in the ~/.vnc/X.log:

     rfbInitSockets: listening on TCP port 5901
     httpInitSockets: listening on TCP port 5801
     rfbCheckFds: got connection
     rfbProcessClientProtocolVersion: client protocol version 3.3 (server 3.3)
     Client Pixel Format:
     8 bits per pixel.
     True colour: max red 7 green 7 blue 3
                 shift red 0 green 3 blue 6
     no translation needed
     using client's preferred encoding: hextile
     rfbProcessClientNormalMessage: ignoring unknown encoding type 3
     rfbSendUpdateBuf: write: No more processes
     Statistics
     ----------
     Framebuffer updates 1, rectangles 1, bytes 25345
        hextile rectangles 1, bytes 25345
     Raw bytes equivalent 1005660, compression ratio 39.678832

Just for kicks I set the encoding preference to "Raw" in the Win32
viewer, which yielded similar results:

     rfbCheckFds: got connection
     rfbProcessClientProtocolVersion: client protocol version 3.3 (server 3.3)
     Client Pixel Format:
     8 bits per pixel.
     True colour: max red 7 green 7 blue 3
                 shift red 0 green 3 blue 6
     no translation needed
     using client's preferred encoding: raw
     rfbProcessClientNormalMessage: ignoring unknown encoding type 3
     rfbSendUpdateBuf: write: No more processes
     Statistics
     ----------
     Framebuffer updates 1, rectangles 1, bytes 1005660
        raw rectangles 1, bytes 1005660
     Raw bytes equivalent 1005660, compression ratio 1.000000

I tracked down the error message to line 526 in the file
Xvnc/programs/Xserver/hw/vnc/rfbserver.c, which was the simple part.

I didn't notice anything *obviously* like this during my perusal of
both the archive for this mailing list and the FAQ.  I also didn't see
a way to do a real search of that archive, tho.

If I don't hear anything from someone on this mailing list, I'll try
to generate more free time to delve deeper on my own.  I was mostly
interested in learning if anyone else had seen a similar problem & had
a handy resolution.

Thanks,
brett
===
Brett M Hogden, Distributed Systems Architect, Rochester Gas & Electric Corp.
e-mail: hogden "at" rge.com       vox: +1.716.724.8729        fax: +1.716.724.8227
   %PGPKey=('375FA761',[1024,'B18D 7E77 7D0A 84AE  C249 A4CC 2E1D B594'])

-----BEGIN PGP SIGNATURE-----
Version: 2.6.3
Charset: ascii

iQCVAgUBNPxvlpGvcU43X6dhAQEP9gP8CY0UPKEE4QB2lWWtPUsXRp0Hh+K/twC1
kdIgAuVZByXShtmRJnv1mVhOtBs8bdWe1nE9BCc/r77DWXXePd28GNh3O2K91J3b
vRq/NYwyaiF21SHgAjY3v1sQ8e8qIDDoRYsrrl5emSNfbiaao+VEq1Pu6on6yChD
0i4P+VLbkN8=
=GyJq
-----END PGP SIGNATURE-----