HP compile problems

Tristan Richardson tjr "at" orl.co.uk
Tue, 03 Mar 1998 11:24:30 +0000


> The server is a bit bigger of a problem. After adding appropriately
> edited config files for the hps, I have managed to get all the code to
> compile, but I get the following error when trying to link.
> 
> /usr/ccs/bin/ld: Unsatisfied symbols:
>    XTestJumpPointer (code)
>    XTestGetPointerPos (code)
>    XTestGenerateEvent (code)
> 
> The file Xvnc/programs/Xserver/Xext/xtest1.frags tells me to implement
> these and checkout server/ddx/hp/hp/x_hil.c for details. I have located
> the appropriate files in the X11R6.3 release but I don't understand what
> I'm trying to do well enough to finish the job. Any pointers would be
> greatly appreciated.
> 

I think the problem here may be that your hp config files are trying to
include the extension called "XTestExtension1".  All the other platforms
ignore it.  Try making sure the symbol XTESTEXT1 isn't defined.  If that
doesn't work try to hack it out by whatever means possible - it's not an
important part of the X server.

Hope this helps

Tristan

+--------------------------------------------------------------------+
|  Tristan Richardson                 Email:  tjr "at" orl.co.uk          |
|  ORL                                  Tel:  +44 1223 343000        |
|  24a Trumpington Street               Fax:  +44 1223 313542        |
|  Cambridge, CB2 1QA, UK               WWW:  http://www.orl.co.uk/  |
+--------------------------------------------------------------------+
|          ORL - The Olivetti & Oracle Research Laboratory           |
+--------------------------------------------------------------------+