"Read failed" win32 vnc server

Stephen Hardman hardguy "at" continuity.it.net.au
Mon, 02 Mar 1998 01:27:43 +0000


Hello,

Recently I installed the win32 and linux side VNC utilities.

My only concern is vncviewing the win95 desktop. I installed VNC
on the win95 box, I ran the "install default registry settings"
program (perhaps this was my mistake), loaded winvnc and entered
just a simple 4 letter password, made it desktop '1'.  Nothing
appeared to be wrong.

On Linux (Debian 1.3.1, 2.0.33, 40MB RAM, XF86), I ran -
vncviewer computer:1   (computer being the name of my other computer :))

The following occured.

vncviewer: VNC server supports protocol version 3.3 (viewer 3.3)
Password:
vncviewer: VNC authentication succeeded
vncviewer: read failed
continuity$

So it appears that it gets to the password prompt (ie. the other end
is responding), it succeeds when I enter the correct password (I tested
it with a wrong password just to make sure), then 'read failed' which
I suspect is at the fault of the Win95 box, as I have successfuly
vncviewed another Win95 box remotely via modem just to test it.

The Win95 box is running a fairly old version of Win95, it's a slow
old dx2/66 with hardly 16MB RAM.  You encounter the same 'read failed'
error when you shutdown the Win95 side of the server (when it's working
that is).

I would really love to get this working after seeing how well it worked
via a fairly average modem link, if anyone has any ideas (is the registry
settings a possible cause?) could they pleeeease help?  Thanks.

Oh yeah! One more thing, since the only way to download the files from
the web page is via the form buttons, I have been unable to get any
win32 test versions since R4 because the cache will only send me that
version, if the filename has Rx in it then I could overcome this problem,
no doubt hundreds of people are downloading old versions thinking it's
a new one. Alternatively, how come the win32 version isn't on the FTP
site?  Only the others are there, and are they updated with the ones listed
on the web?

Regards
Steve Hardman