Can't run apps on virtual server....

Hugo van der Kooij hvdkooij "at" caiw.nl
Sun, 01 Mar 1998 09:15:18 +0000


On Sun, 1 Mar 1998, Mazurka wrote:

> I can start up vncserver, but I can't run apps on the virtual
> desktop.  That is, the server initializes the net sockets correctly,
> but when the default startup script (~/.vnc/xstartup) tries
> to run xrdb, xsetroot, and xterm, it can't connect to the 
> virtual desktop server.  (see X.log errors below.)
> I'll get the same error if I try to run an xterm to it myself.
> 
> HOWEVER, I can connect to the virtual server with vncviewer
> on a Win95 box and a Solaris box.  It just shows a blank X background.
> 
> Yes, I've unpacked the fonts, did a mkfontdir, and /tmp/.X11-unix
> is rwx for everyone.  I'm on RedHat5.0 Linux on a Pentium.
> Similar result if I run this as root or not.
> 
> Any ideas?   Thanks.
> 
> 
> Output from X.log
> -------------------
> $ more X.log
> rfbInitSockets: listening on TCP port 5901
> httpInitSockets: listening on TCP port 5801
> _X11TransSocketINETConnect: Can't connect: errno = 101
> xrdb: Network is unreachable
> xrdb: Can't open display 'clanbs.stanford.edu:1'

you have a bad IP configuration! Fix the networking stuff and all should
be well.

Hugo.

	+------------------------+------------------------------+
	| Hugo van der Kooij     | Hugo.van.der.Kooij "at" caiw.nl   |
	| Oranje Nassaustraat 16 | http://www.caiw.nl/~hvdkooij |
	| 3155 VJ  Maasland      | (De man met de rode hoed)    |
	+------------------------+------------------------------+
    "Computers let you make more mistakes faster than any other invention in 
      human history, with the possible exception of handguns and tequila."
		(Mitch Radcliffe)